7 Replies Latest reply on Oct 28, 2009 12:48 PM by etripoli

    Possible Leopard issue - no admin console for FMS 10.2

    dhrowe10

      Summary

      Possible Leopard issue - no admin console for FMS 10.2

      Description of the issue

      FileMaker Server 10.2 on W3k box. Operating System(s) involved:Mac 10.6.0This does not happen on my Win XP sp3 machines or OSX 10.5.x or 10.4.x machines Detailed description of the issue:I loaded 10.6.0 on a machine today.  I can not get the admin console to work.  The older ones from before I killed.  I try to download a fresh one from xxx:16000 and I get a failed to Validate certificate.Exact steps to reproduce the issue:Browser to xx:16000/  ( same with two different servers)  Click 'Start Admin Console" Expected Result:get an admin consoleActual Result:Jmpstart file downloads.Get Dialog window from Java: Warning Security Exact text of any error message(s) that appeared:Failed to validate certificateThe application will not be executed  java.security.cert.CertificateException: Unable to evaluate certificatesat com.sun.deploy.security.MacOSXTrustUI.evaluateTrustAndShow(MacOSXTrustUI.java:147)at com.sun.deploy.security.MacOSXTrustUI.showDialog(MacOSXTrustUI.java:47)at com.sun.deploy.security.X509Util.showSecurityDialog(X509Util.java:152)at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(TrustDecider.java:663)at com.sun.javaws.security.AppPolicy.grantUnrestrictedAccess(AppPolicy.java:264)at com.sun.javaws.LaunchDownload.checkSignedResourcesHelper(LaunchDownload.java:1460)at com.sun.javaws.LaunchDownload.checkSignedResources(LaunchDownload.java:1170)at com.sun.javaws.Launcher.prepareLaunchFile(Launcher.java:1020)at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:306)at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:183)at com.sun.javaws.Launcher.launch(Launcher.java:104)at com.sun.javaws.Main.launchApp(Main.java:405)at com.sun.javaws.Main.continueInSecureThread(Main.java:252)at com.sun.javaws.Main$1.run(Main.java:111)at java.lang.Thread.run(Thread.java:637)show certificate details, shows a class 3 cert from FMI.... so don't know exactly what is going wrong. Any additional configuration information/troubleshooting that is relevant to the issue:Admin console works fine on other machines on network, just the Snow Leopard box has this issue. Any workarounds that you have found:  use other client.

        • 1. Re: Possible Leopard issue - no admin console for FMS 10.2
          dhrowe10
            

          Just to be clear.  This is an existing FMS 10 ( on W3K) v 10.2.  The problem is getting the admin console to run an a Snow Leopard box.

           

          1. Using the Java Preferences App in the Utilities folder clean the  
          JAVA cache in the Network Tab and delete all apps from the Security tab.

          did this

          2. Restart the computer

          did this

          3. Try to connect to the FMS computer using just the standard URL. Do  
          not use port 16000 yet.

          this does not work.  eg its http://x.x.x.x/ the servers web but the server is a dual, and W3k x.x.x.x  addr is the server addr not the web addr.
          Regardless this client can see and run as a client of that server  ( run fmp )
           
          However when I go to :16000 all the links on that page work correctly. 

          If the connection goes through then:

          4. Attach port 16000 to the working URL 

           

           

          It shows the correct page in my browser, when I say to launch, it downloads the .jnlp file, but I still get the error.

          When I look at the certificate, it says that it doesn't expire until 2011, but I still get the Java error that it is unable to evaluate the certificate.

          The same thing happens when I try to download the PHP assistant.  It downloads, and launches the Application, then gives the same certificate security error.

           

          • 2. Re: Possible Leopard issue - no admin console for FMS 10.2
            TSGal

            dhrowe10:

             

            Thank you for your posts.

             

            It's not clear from your posts if you reinstalled FileMaker Server after installing Snow Leopard.  I confirmed with a machine in another location that FileMaker Server 10v2 works with Snow Leopard.

              

            TSGal

            FileMaker, Inc 

            • 3. Re: Possible Leopard issue - no admin console for FMS 10.2
              dhrowe
                

              I have a client machine, that I was using to run the admin.  It was actually running Tiger.

               

              I didn't touch the server.

               

              I upgraded the client machine to Snow Leopard.

               

              I cannot get the Admin console to work on this machine.

               

              I did not feel the need to reinstall FMS to make the console work on a client machine??

               

              doug 

              • 4. Re: Possible Leopard issue - no admin console for FMS 10.2
                TSGal

                dhrowe:

                 

                Thank you for the additional information.

                 

                I assumed incorrectly that the Admin Console was being run on the same computer as the server.  Therefore, there is no reason to reinstall FileMaker Server.

                 

                Wondering if it was a Snow Leopard problem, I went to a Snow Leopard (Mac OS X 10.6) machine and accessed the server via the browser at:

                 

                IP address:16000

                 

                Everything downloaded properly, and I was able to successfully launch the Admin Console.  Therefore, we need to look elsewhere.

                 

                Launch Java Preferences.  I am using "Java SE 6" in 32-bit mode, but I believe "Java SE 5" in 32-bit mode should also work.

                 

                When the admin_console_webstart.jnlp file downloads, make sure it is set to open with "Java Web Start (default) 13.0.0"

                 

                Any other information you can provide may help me determine the differences between our systems.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: Possible Leopard issue - no admin console for FMS 10.2
                  dhrowe
                    

                  Nope thats not it. ;-(

                   

                  It downloads the file.  If I right click it and set it to open with Java Web Start, I get exactly the same result as before.  It starts and doesn't like the certificate.

                   

                  This is a Snow leopard install that I upgraded from Tiger.

                   

                  For fun I tried using another account.  It works fine, so there is something corrupt or set incorrectly in my user account, and by the lack of comments is not very common.

                   

                  Only unique things about the account.  It is a mobile account.  I am using and did some sync with my Me account. 

                   

                  I may try to reinstall Snow Leopard from scratch, and see what happens.  But I rather not loose the day setting the machine back up.

                   

                  • 6. Re: Possible Leopard issue - no admin console for FMS 10.2
                    TSGal

                    dhrowe:

                     

                    Thanks for checking your system and comparing it to mine.

                     

                    The last thing I would want you to do is "reinstall Snow Leopard from scratch".  If that didn't work, you would still be back at step #1 and more frustrated.  On top of that, you were able to get the Admin Console working from a different user account, so I'm fairly certain Snow Leopard is installed properly.

                     

                    At this time, Snow Leopard is less than two weeks old, so we (FileMaker, Inc.) hope everything works as expected.  That is why I tested your scenario to make sure we didn't have a problem with Admin Console being launched from a remote machine.

                     

                    I don't have a MobileMe account, or I would try the sync to see if this affects Admin Console.  Until someone else encounters a similar problem, you'll have to do some sleuthing.  I would start first by turning off the syncing, rebooting and try again.  If this fails again, then turn it back on and then start comparing the two user accounts.  If I think of anything else, or if someone else reports the same problem, I will let you know.

                     

                    If you do find out what caused the problem, please post it here in case others run into the same problem later.

                     

                    Sorry I can't be of more help at this time. 

                     

                    TSGal

                    FileMaker, Inc. 

                    • 7. Re: Possible Leopard issue - no admin console for FMS 10.2
                      etripoli
                        

                      It appears that the issue is related to migrating 10.4 (Tiger) to 10.6 (Snow Leopard).  I am having similar problems, and it is because KeyChain thinks the certificates used by the Admin Console Java app are expired.  As a workaround:

                       

                      1. open KeyChain Access

                      2. select Show Expired Certificates from the View menu

                      3. locate the FileMaker, Inc. certificates in the Certificates category

                      4. Select one, chose Get Info from the File menu

                      5. Click the drop-down arrow next to Trust

                      6. Change When using this certificate: to Always Trust

                      7. Close and repeat