13 Replies Latest reply on Mar 25, 2009 7:34 AM by TSGal

    Printing Problem with MS Vista - FM8.5

    kvogel

      Summary

      Printing Problem with MS Vista - FM8.5

      Description of the issue

      FM8.5OS: MS Vista Problem: When atempting to print, I get the following error: PCL XL error Subsystem: KERNEL Error: IllegalTag Operator: 0x00 Position: 3 I had no issues using FM8.5 on XP, and no other software is affected by Vista.  I have added the Vista patch that resolved the black screen issue...

        • 1. Re: Printing Problem with MS Vista - FM8.5
          TSGal

          kvogel:

           

          Thank you for your post.

           

          If this is your first time printing, go into Print Setup and make sure you have the proper printer selected.  It may default to the old setting or to a default setting that isn't directed to an installed printer.  Once that is set, then try Print again.

           

          If you are still getting the error, see if you are able to Save Records as PDF, open the PDF file and print.  Does this work?

           

          Please keep me posted.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Printing Problem with MS Vista - FM8.5
            kvogel
               The printer settngs are correct, and the printer is being reached (thus the error message that is printing out) ... all other programs are printing with no difficulty.  I am able to save as .pdf ... but that's really inconvenient.
            • 3. Re: Printing Problem with MS Vista - FM8.5
              TSGal

              kvogel:

               

              Thanks for the information.

               

              Sorry for the confusion.  I wasn't suggesting to use "Save Records as PDF".  I didn't know where the problem lied, so I wanted to try a number of things to help me narrow down the possibilities.  From your answers, that did help.

               

              Does this happen with all files or one particular file?  Can you try creating a new database file with one table, one field, one record?  Then, try to print.

               

              Is this a local printer or a network printer?  If a network printer, does another computer on the network have FileMaker Pro that is printing?

               

              What kind of printer do you have?  There have been some reports of printers that don't print.  These include, HP P1006, HP 1505, Sharp, Konica, and an Epson come immediately to mind.  I'm looking for the Sharp, Konica and Epson model numbers.

               

              As a long shot, shut down the computer, and then start it again (don't just Restart).  Then, turn off the printer, wait ten seconds, and turn it on again.  Under the Start menu, select "Printers and Faxes".  Double-click the printer being used.  Cancel any stalled jobs and try printing again.

               

              Some users have had some success getting the latest printer driver from the manufacturer.

               

              Make sure there is enough available hard disk space. Windows saves temporary print files to the hard disk when you print.  Most of the time, an error message does not display.

               

              A couple of users had an outdated video driver.  Switching to Standard VGA driver, shutting down the computer and starting again made the problem go away.  This is a long shot, and I doubt this is the problem, but I have to mention it. 

               

              Any additional information you can provide could be helpful.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: Printing Problem with MS Vista - FM8.5
                kvogel
                  

                I just created a new db, and printing worked fine.

                 

                Network printer, HP Color Laserjet3600n.

                 

                Others with FMP are printing fine - and this is the same db that we share, passing the newest version back and forth on a thumb drive.

                 

                As I only have Vista because it's a new machine, my guess is that video drivers, memory, etc are non-issues.

                • 5. Re: Printing Problem with MS Vista - FM8.5
                  TSGal

                  kvogel:

                   

                  Well, we're getting closer.  The file works fine with other machines, but not with the current machine.  Interestingly, a new file does print without a problem, which seems to point down to the file-machine-printer combination.

                   

                  Thanks for the information about the HP Color LaserJet 3600N.  This is definitely not an issue.

                   

                  The other file I had you print from was a very simplistic case, and I'm assuming your layouts are a bit more complicated than just one field.  In the problem file, please create a blank layout, add one field, and then print current record.  Does that work?  I'm trying to determine if it is the original layout and/or the number of objects on the layout that is causing the problem.

                   

                  Do you have access to a local printer?  That is, a printer that is not on the network?  I'm trying to isolate if it is a network printer problem or general printing problem.  Also, try printing from the newly created layout with one field.

                    

                  I have to leave for the day, so I'll talk with you tomorrow.

                   

                  TSGal

                  FileMaker, Inc. 

                  • 6. Re: Printing Problem with MS Vista - FM8.5
                    kvogel
                      

                    So when I create a new layout with only one field, that prints - via the wireless network.

                     

                    Closer and closer...

                    • 7. Re: Printing Problem with MS Vista - FM8.5
                      TSGal

                      kvogel:

                       

                      Thanks for testing this out.  It does appear to be pointing towards the number of objects on the layout, or perhaps a corrupt layout.  If possible, I'd like to see a clone (copy with no records) of the database file.  If it is a corrupt layout, I will fix it.  This will probably save a lot of time instead of trying to add fields back to the layout one at a time.

                       

                      I have sent you a private message (top of this screen - right side - just below the blue bar - X Messages) with instructions where to send the clone file.

                       

                      TSGal

                      FileMaker, Inc. 

                      • 8. Re: Printing Problem with MS Vista - FM8.5
                        kvogel
                           Just sent it - the clone is 6mb - so it might take a bit.
                        • 9. Re: Printing Problem with MS Vista - FM8.5
                          TSGal

                          kvogel:

                           

                          I received your message and file last night.  Unfortunately, you didn't mention which layout nor script that was causing the problem.  I printed from the Guests layout without a problem.

                           

                          If you could let me know which layouts aren't printing and which scripts, that will help me narrow down the problem.

                           

                          TSGal

                          FileMaker, Inc.

                          • 10. Re: Printing Problem with MS Vista - FM8.5
                            kvogel
                               Guests has been a problem for me.  The others I've been trying are Order Component Printout - Individual and Summary.
                            • 11. Re: Printing Problem with MS Vista - FM8.5
                              TSGal

                              kvogel:

                               

                              The Guests  and Order Components Printout (Individual and Summary) layouts are fine.  No corruption.  I can also print from all three layouts.

                               

                              Does the information appear properly in Preview Mode?  Whatever shows in Preview Mode is being sent directly to the printer driver.  If this is displaying properly, then either the network printer driver is corrupt or the network spooler is not set up to handle large amounts of data.  Check with your system Administrator for the spooler size.  Another possibility is that the printer driver is not installed correctly.  If you are familiar with adding a printer to your system, then perform the following steps:

                               

                              1. Go to Control Panel and select "Printers and Faxes"

                              2. Delete the existing printer driver for your network printer

                              3. Add a printer, selecting the printer on the network.

                               

                              This adds a new connection to the same printer.

                               

                              Try printing again.

                               

                              Continue to keep me posted with your progress.

                               

                              TSGal

                              FileMaker, Inc. 

                              • 12. Re: Printing Problem with MS Vista - FM8.5
                                kvogel
                                   Preview works fine.  If the printer driver is corrupt, wouldn't that impact other programs?  I'm only having issues printing from FMP.  Same thing with the spooler size ... others on the nework can print just fine.  The biggest difference in play is that I'm on Vista and they're on XP.
                                • 13. Re: Printing Problem with MS Vista - FM8.5
                                  TSGal

                                  kvogel:

                                   

                                  I moved your file to a Dell Optiplex 740 running Vista Business.  No printer installed, so saw that an HP LaserJet P3005 printer was sitting close by, I installed the HP LaserJet 3015 driver, connected it to the IP address for that printer, tested it, and the test page printed correctly.

                                   

                                  I launched your file, and it defaulted to FileMaker Pro 10.  I selected the Guests layout, and it printed fine.

                                   

                                  I installed FileMaker Pro 8.5, and then the update to 8.5v2.  Opened your file with FileMaker Pro 8.5 and printed the same Guests layout without a problem.

                                   

                                  I'm not quite sure what to try next here. 

                                   

                                  TSGal

                                  FileMaker, Inc.