2 Replies Latest reply on Jul 10, 2013 8:48 AM by NAkars

    Problem networking host computer to iPads running FM Go 12.0.7

    NAkars

      Summary

      Problem networking host computer to iPads running FM Go 12.0.7

      Product

      FileMaker Go

      Version

      12.0.7

      Operating system version

      OS X 10.0.5

      Description of the issue

      We are trying to link three iPads and two laptops via an ad hoc network to a host computer, a MacBook Pro running OSX 10.0.5.  We create the network on the MacBook Pro, using a static IP address.  When the network is set up, the other laptops (running FM Pro 12.0.4) and an iPad running FM Go 12.0.2 can see the network and connect to our database on the host computer with no problem.

      However, the iPads running FM Go 12.0.7 will not open the database.  They say that they are seeing our network, but they do not see any files available from FileMaker.  That is, when I open FM Go, I search for a local network host.  The network comes up, and I click it.  On the next screen, the database does not pop up.  Instead, I get an "Enter Filename" button, but underneath the button, it says "No network connection is available."  If I type in the database filename manually, I get another error: "The file could not be opened. (Not Found)"

      Steps to reproduce the problem

      On host computer:  Choose "Create Network," then "OK" (no security).  Then in Network Preferences, choose "Advanced" on the Wi-Fi tab.  In Advanced, "TCP/IP" with Using DHCP with manual address (or Manual, doesn't seem to matter), input static address, hit "OK", and then on Network Preferences screen, hit "Apply".  Then open FM Pro, go to the File menu, hit Sharing, share FileMaker Network, share for all users, and hit "OK". 
      On iPads: Go to Settings, WiFi, connect to the local network.  Go to FM Go, search for remote host, choose local network host, choose database that is available on local host.

      Expected result

      Database opens, we enter data, all is right with the world.

      Actual result

      After choosing the local network host on the iPads (only those running FM Go 12.0.7, not the one running FM Go 12.0.2), the database does not show up, and entering it manually does not work.

      Exact text of any error message(s) that appear

      When I click on the local network host, I get an "Enter Filename" button, with a message underneath that says "No network connection is available."  If I enter the filename manually, "Error.  The file...could not be opened. (Not Found)"

      Configuration information

      No firewalls or antivirus software are running on the host machine.  We've tried to configure the network using DHCP instead of DHCP with manual address or Manual address.  We've tried to configure the iPads to use static IPs and DHCP.  We've tried turning them off and turning them on.  We've tried clearing the settings on the iPads.  We've tried to reinstall everything.  We've tried to connect with the problem iPads before anything else is connected (so that there's no possibility that there are too many devices on the network).  We've talked to Apple support and they couldn't come up with a fix on the iPad side.

      14.png