1 Reply Latest reply on Aug 11, 2010 4:24 PM by hschlossberg

    Problem with a Scheduled Script using the 'Perform Script' step when running on FMServer

    alan.stirling

      Summary

      Problem with a Scheduled Script using the 'Perform Script' step when running on FMServer

      Product

      FileMaker Server

      Version

      10.0.2.206

      Operating system version

      Mac OS 10.6.2 (Server)

      Description of the issue

      I cannot get FMServer when running a scheduled FileMaker Script, to run a 'Perform Script' step pointing to another FMP file, if the file is in a different folder on the same server. I get an 'Error 100 - File Is Missing'.  The same script step DOES work when pointed to an FMP file in the same folder on the server.

      Steps to reproduce the problem

      Write a server script in FileMaker which includes the Perform Script step.  Point this step at a file on the server, but in a different server folder.  Check the error returned after the script has run. It will be 100.

      Expected result

      If the Perform Script step points to a file in the same server folder, the script runs correctly, returning an error code of 0.

      Actual result

      Following the 'Perform Script' in another file step, the error code returned is 100 - (File is Missing).

      Exact text of any error message(s) that appear

      This is a server script, so there are no messages returned.

      Workaround

      Make sure that any files that need to communicate using a Perform Script step are in the same server folder.