AnsweredAssumed Answered

Problem With Web Viewer Only In Preview Mode

Question asked by mleering on May 21, 2014
Latest reply on Oct 21, 2014 by TSGal

Summary

Problem With Web Viewer Only In Preview Mode

Product

FileMaker Pro

Version

13.03

Operating system version

Win 7x64

Description of the issue

I've created an Org Chart using the data protocol, and some javascript libraries that can be found at the following address:

http://librerias.logicas.org/lib_gg_orgchart/


Everything works fantastic in Browse mode, but I need a printable version of this too, and I would like to stay in FileMaker for the printable version.  The problem that I'm running into is that my entire Org Chart disappears when I enter preview mode.


I understand that web viewers maintain their state when switching between browse/preview mode
I've given the web viewer a name, and can tell that it still has the proper content (using GetLayoutObjectAttribute)
I've tried removing everything that I can from the HTML (before the JS mods happen) without success

This problem still persists though.

Steps to reproduce the problem

Enter Browse Mode --> Chart renders fine
Enter Preview Mode --> Chart disappears

Expected result

Seeing as how the web viewer is not even supposed to have to re-evaluate the contents of the web viewer when switching between browse/preview mode, I was expecting to still be able to see my chart.

Actual result

Web viewer appears empty

Exact text of any error message(s) that appear

N/A

Configuration information

Win 7x64 SP1
FileMaker Pro Advanced 13.03
IE 11


Post was already made on TechNet:
https://fmdev.filemaker.com/message/147900#147900
See attachment there for sample HTML

Workaround

Chart still renders fine while on a Mac OS with Safari

Outcomes