8 Replies Latest reply on Mar 3, 2011 7:06 AM by amyh

    program not recognizing priveleges settings

    amyh

      Summary

      program not recognizing priveleges settings

      Product

      FileMaker Pro

      Version

      805 Advanced

      Operating system version

      Windows XP

      Description of the issue

      I have reset all accounts and priveleges (eliminating all except one) to Admin with no password since I am the only user.  I have set "File Options" to automatically open with this info. When I try to open a file, it will not recognize the Admin option, though it will let me in if I hit "cancel".  Any idea what's going on?

      Exact text of any error message(s) that appear

      The account and password you entered cannot be used to access this file. Please try again.

        • 1. Re: program not recognizing priveleges settings
          philmodjunk

          Do you have the "guest account" option enabled in File Options? That should not be enabled, I'm speculating that that is how you are able to open the file by clicking "cancel". Once you get the file open, is it open with full access or limited privileges?

          Do you have a back up copy that predates these changes you've made in Manage | Security?

          With that backup copy, you can at least start over and try again to get things set up the way you want them to be.

          • 2. Re: program not recognizing priveleges settings
            amyh

            I have other files that never had any security settings, and they work fine.  It's only the ones I changed - and previously I had to use a username and password to access them.

            • 3. Re: program not recognizing priveleges settings
              philmodjunk

              Make sure that file options is set up in this fashion:

              1. Log In using is selected
              2. Using Account Name and Password is selected
              3. Admin is entered into Account Name
              4. Password is blank

               

              In Manage Security, make sure that an Account named Admin with no password specified is set up with Full Access privileges

              One final gotcha to avoid, make sure that this is also done for any other files this file may open either by script or layout reference.

              • 4. Re: program not recognizing priveleges settings
                amyh

                There is no guest account.

                The settings are all as advised above.

                The previous version had the security - there is no older version around without it.  The program software was reloaded, but that hasn't helped either.  There must be some sort of glitch in my system.

                • 5. Re: program not recognizing priveleges settings
                  philmodjunk

                  When I referred to back up copies, I was responding to this statement:

                  "I have reset all accounts and privileges (eliminating all except one) to Admin with no password since I am the only user."

                  I understood that to mean you had made recent changes to your security settings just prior to seeing this problem. Anytime you modify security settings, it's a good idea to save a copy first so that if you accidentally lock yourself out of the file, you can just discard it, open the back up copy and try again. If this sentence describes one of your attempts to fix the problem, please disregard this suggestion.

                  What still seems strange, is that you say you were able to click cancel and still get the file open. Does this file link to any other filemaker files? If you open file 1 and it encounters a reference to a second file--this can be do to a related field on a layout or a reference in a script, it's possible that you could get the password log in prompt for file 2. Clicking cancel could then permit you to go ahead and use file 1. It's just that you won't have file 2 open--something that might otherwise leave file 2 open in the background where you can't see that it's open unless you check for it. That's just one possible explanation that comes to mind that fits what you describe here.

                  • 6. Re: program not recognizing priveleges settings
                    amyh

                    Yes, the file links to other files, but they have all been reset to "Admin"/no password.

                    I get the log in request for every file, but they all open if I hit "cancel", and they all stay open until I manually close them.

                    The problem did start with the security changes, but I was using a back-up file to make the changes.  Going back to it doesn't make sense to me. At this point, updates have been made in the database, and going back will erase data.

                    • 7. Re: program not recognizing priveleges settings
                      philmodjunk

                      It's an option if you can't get the file open in full access mode--I'm not sure if you are able to do that or not.

                      I'd test the file by isolating the file, move it to a different computer or move/rename all the other files  or make a copy and delete all the entries in manage | External Data sources... and see if I still got the password dialogs. That would at least tell me whether this is caused by a reference to an external file or the current file. I'm guessing that an external file reference is triggering this. In which case the issue is more likely to lie with that external file and it could be just one file out of the total set. That file could even have some file corruption that is causing it to not "recognize" the account name and password settings fo the main file.

                      • 8. Re: program not recognizing priveleges settings
                        amyh

                        You were right!

                        I went through all of my relationships and found one I had missed.  Once I updated that password, the rest worked as they should.

                        Thanks for all of your help.