1 2 Previous Next 29 Replies Latest reply on Aug 4, 2017 10:56 AM by destroid

    Progressive Backup - Save button does not work

    danshockley

      Summary

      Progressive Backup - Save button does not work

      Product

      FileMaker Server

      Version

      13.0.4.400

      Operating system version

      Mac OS X 10.8.5

      Description of the issue

      I attempt to enable Progressive Backups. I enter 15 for the interval (or leave it at the default 5). I enter a known-valid backup path (tested it with the schedule interface) that is neither a sub-folder nor a parent folder of any other backup or of the hosted files. It is on a different, local hard disk to which scheduled backups run properly without error.

      When I enter that path, there is no message saying that either the path is valid or it isn't. Clicking the Validate button does nothing. Clicking the Save button does nothing. If I try to leave the "Database Server" section of the interface, I am told I "have unsaved changes" and must "save or revert before continuing." Save still does nothing - no error message, no successful save. If I then uncheck the Enable Progressive Backups button, I still cannot leave the interface as I have "unsaved changes." I can only escape by clicking Revert, leaving Progressive Backups off.

      I'd like to use progressive backup, but can't turn it on.

      Steps to reproduce the problem

      Enable Progressive Backups.
      Enter a save interval.
      Enter a valid path.
      Click Validate and/or Save.

      Expected result

      The path validates (or says it failed to). The interface saves the new settings.

      Actual result

      Nothing happens at all.

      Workaround

      None found.

        • 1. Re: Progressive Backup - Save button does not work
          Markus Schneider

               probably, the path is wrong )-:

               The only way to solve this 'path issue' that happens every now and then with FileMaker Server can be done by FileMaker - please let users select/create paths using a regular 'file/folder selection dialog' from the OS 

          • 2. Re: Progressive Backup - Save button does not work
            danshockley

                 The path is not wrong. I tested it using the scheduled backup interface: valid path. Also, even when I put in a blatantly non-valid path, the validate button does nothing. In my description above, I describe that the interface does not indicate anything at all. 

                 One additional detail: when I was typing in the path and had the cursor over the text field, the tooltip appeared and said that the path could not be empty (after the entire path was typed in). Bizarre. It seems to me like the admin console is somehow ignoring that there is anything entered at all. 

                 Is it considered good practice to have permissions ignored for the backup volume, as I do here?

            • 3. Re: Progressive Backup - Save button does not work
              danshockley

                   Anyone seen this issue? Any thoughts on things I can try that I haven't already described trying to do?

              • 4. Re: Progressive Backup - Save button does not work
                RickWhitelaw

                     If you're doing this remotely you should know that for an external drive to be used, a user must be logged into the server machine. you can, on Mac OS anyway, still set the screen to lock, but you must be logged in.

                • 5. Re: Progressive Backup - Save button does not work
                  danshockley

                       Hmm. There is a user logged in. I screen share to control it, but it definitely is not left at the boot user login screen. 

                  • 6. Re: Progressive Backup - Save button does not work
                    RickWhitelaw

                         Of course I mean logged in at the OS level and must have proper permissions to use the drive . . .

                    • 7. Re: Progressive Backup - Save button does not work
                      danshockley

                           I've tried with "Ignore Privileges on this volume" set. Same problem. I've tried with the folder owner:group set to fmserver:fmsadmin. Same problem. In both of those scenarios, the scheduled backups worked properly, but the Progressive Backups admin interface had the same problem (the Validate button does nothing - not "valid" and not "invalid"). 

                           There is a user logged in at the OS level - I am using screen share to access it, but using Safari running ON that server to use the admin interface. 

                      • 8. Re: Progressive Backup - Save button does not work
                        RickWhitelaw

                             It's a pain. I'm away from my office now for some time. Although I can access all files on the server, Admin Console tells me that backups are failing. What this means to me is that there was a brown-out at the office, the server machine automatically restarted. FMS automatically restarted, but there is, of course, no log-in. So the external drive shows as an invalid path in Schedules. Luckily I'm not making a lot of changes and, if I do, I can download the files to my laptop. "Another backup". Sheesh!

                        • 9. Re: Progressive Backup - Save button does not work
                          danshockley

                               Anyone from FileMaker able to respond to this? Even with other things to try? 

                               The behavior (or lack thereof) of the Validate and Save button makes it seem like the interface thinks I haven't typed anything into the path field at all. In fact, I remember at one point while typing in the path, I saw a brief glimpse of a tooltip on the field (mouse hovered briefly over the field) saying that the field could not be empty. That was after I had typed in about half of the path. 

                          • 10. Re: Progressive Backup - Save button does not work
                            TSGal

                            DanShockley:

                            Thank you for your posts, and I apologize for the late response.

                            I have not encountered this behavior of the Admin Console not letting me know if the path is valid.  I realize this doesn't help you.

                            Is it possible the remote screen sharing is not performing perfectly?  Rather than screen share, physically go to the server, launch a browser and access Admin Console directly.   See if you can save Progressive Backups to the local drive.  This will help narrow down the number of possible causes.  If this fails, I would close the database files, move them to the Desktop, uninstall and reinstall FileMaker Server, and then place the databases back in the appropriate folders.

                            TSGal
                            FileMaker, Inc.

                            • 11. Re: Progressive Backup - Save button does not work
                              spliceguy

                              I have just encountered the same problem. I am trying to switch on progressive backups, the path is valid, but nothing happens on pressing the save button, just a nag screen when trying to leave the page saying "you have unsaved changes...etc". This happens on a local and remote save location. I am working directly on the server, not through remote desktop. 

                              jon

                              • 12. Re: Progressive Backup - Save button does not work
                                TSGal

                                Jon Dawson:

                                Thank you for your post.

                                What version of FileMaker Server are you running?

                                What operating system is being used on the server?

                                What is the local save location being used?

                                TSGal
                                FileMaker, Inc.

                                • 13. Re: Progressive Backup - Save button does not work
                                  chivalry

                                  I'm having the same issue.

                                  FileMaker Server 14.0.2.226 running on OS X Yosemite 10.10.3. Attempting to set progressive directory to `filemac:/Frodo/Library/FileMaker Server/Data/Progressive/`. That directory is owned by `fmserver` with group `fmsadmin`. It has the same privileges as `filemac:/Frodo/Library/FileMaker Server/Data/Backups/` (`drwxrwxr-x`).

                                  Click "Enable progressive backups", enter above progressive directory path in "Path". "Validate" and "Save" buttons have no discernible effect. Clicking "Status" on left results in unsaved changes message, can only "Revert" to get out.

                                  • 14. Re: Progressive Backup - Save button does not work

                                    Charles Ross:

                                     

                                    Thank you for the reply.

                                     

                                    I am not able to replicate. To attempt to replicate, I performed the following steps:

                                     

                                    1. Installed and deployed FileMaker Server 14.0.2

                                    2. Created a folder called “Progressive” at the following path:

                                     

                                    HardDriveName/Library/FileMaker Server/Data/Progressive/

                                     

                                    3. Get Info on the Data folder > Unlocked the Lock > Permissions gear > “Apply to enclosed items…” > Clicked “OK”

                                    4. Logged into the Admin Console

                                    5. Database Server (pane) > Folders (tab) > Checked “Enable progressive backups”

                                    6. Pasted the following path:

                                     

                                    filemac:/HardDriveName/Library/FileMaker Server/Data/Progressive/

                                     

                                    7. Clicked “Validate” and received a "Valid Path" prompt

                                    8. Click “Save” and received “Save Successful” prompt

                                     

                                    Since I cannot see any difference in your steps and mine, at this point, I would suggest uninstalling FileMaker Server 14.0.2 and reinstalling. 

                                     

                                    Please keep me updated with any progress and let me know if I missed a step to replicate. 

                                     

                                    TSFalcon

                                    FileMaker, Inc.

                                    1 2 Previous Next