3 Replies Latest reply on Apr 15, 2011 10:51 AM by LaRetta_1

    Record duplication changes date but not timestamp

    BarbaraWray

      Summary

      Record duplication changes date but not timestamp

      Product

      FileMaker Pro

      Version

      11.0

      Operating system version

      Windows7

      Description of the issue

      I duplicate a record.  The new record looks the same but has a new date.  Good.  However, it has the previous time stamp.  This is a problem when trying to import additional data to many records based on the time it was entered.  When sorting by created date (and time), it is off.

      Steps to reproduce the problem

      Add new record in inventory module.  Fill in data.  Press [record].  Press [duplicate].

      Expected result

      Duplicated record with new date and time stamp.

      Actual result

      Duplicated record with new date and old time stamp.

      Exact text of any error message(s) that appear

      None.

      Workaround

      None.  Do you have any?

        • 1. Re: Record duplication changes date but not timestamp

          Barbara Wray:

          Thanks for posting.

          The only way I was able to reproduce this behavior is if my timestamp field used an auto-enter calculated value and had the "Do not replace existing value (if any)" option enabled.

          If this is the current setup for your field, you should be able to resolve this issue by disabling that option. Head to File -> Manage -> Database, select your field and click Options. In the first tab of the resulting dialog (Auto-Enter), uncheck the "Do not replace existing value (if any)" option. 

          If this isn't the case, please let us know how the field is currently set up.

          TSBear

          FileMaker, Inc.

          • 2. Re: Record duplication changes date but not timestamp
            BarbaraWray

            This worked well.  Thank you so much.

            • 3. Re: Record duplication changes date but not timestamp
              LaRetta_1

              Hi Barbara,

              “Expected result:  Duplicate record with new date and timestamp
              Actual result: Duplicated record with new date but old time stamp”

               Correct me if I’m wrong, but if you want newly created (whether imported or duplicated) records to have their OWN creation date and creation time then why aren’t you using the auto-enter feature designed for it? 

              When you open the auto-enter tab, the first two options (creation and modification) have a popup where you can chose auto-creation of date, time, user etc.  Then if you import new records or duplicate a record, the new record will ALWAYS inherit the new date and time. 

              If you use the auto-enter CALCULATION option (and particularly if you uncheck ‘do not replace existing values if any’, you are using a lot of  resources needlessly.

               Even if your currently are using an auto-enter calculation for that time field, you can change it now since it only will act when a record is first created.  I strongly encourage you to take advantage of the auto-enter creation and modification functions.  :^)