AnsweredAssumed Answered

Referenced images not showing in calculated container field

Question asked by conchology on Feb 19, 2012
Latest reply on Feb 20, 2012 by TSGal

Summary

Referenced images not showing in calculated container field

Product

FileMaker Pro

Version

11 & 11 advanced

Operating system version

OS X 10.5, OS X 10.6, OS X 10.7

Description of the issue

Images are not showing up in Filemaker 11 but are showing correctly in Filemaker 10.

The images are shared by an OS X 10.5.8 server with AFP protocol and in Filemaker we use a referenced calculation container to display the image.

Images are stored in JPG and have read/write permission for all users & groups.

Read more: http://forums.filemaker.com/posts/1b2fc53fdb
Similar but not the same bug: http://forums.filemaker.com/posts/52cf44da3c#174697

Steps to reproduce the problem

My setup:
- FileMaker Server Advanced 9 running on 10.5.x on Xserver, never had any problems with it, just zooming along and doing its job.
- OS server 10.5.8 for storing our images and make with afp them available to all our staff.
- FileMaker Pro 10: about 20 staff members to access a few databases, of which one that contains about 1.7 million records.
- Macs only: OS X ranging from 10.5 to 10.7

Database structure:
- about 1.8 million records, something like 25 fields, a few calculations, etc...
- all records have 1 image referenced to in a calculated container field, the path is directed to images stored on a volume mounted on each computer.
- calculation field result in container with path: "image:/Images Stamps/1000000/web/1002098.jpg"

Images:
- saved in .jpg using Adobe Photoshop.
- average size is about 1MB

The problem:
- In FMP 10 we can see all the images of the 1.8 million records without any problem.
- In FMP 11 we can see a few images random images, mostly it stays empty. 
- a screenshot is added to show the issue

I could also reproduce the same error with a standalone FMP file on a desktop computer trying to display the files from a remote server with AFP or trying to display the same images stored on the local volume.

Expected result

Images to show in FMP 11.

Actual result

No images are showing at all or sometimes correct images are displayed at random in FMP 11.

Exact text of any error message(s) that appear

The file cannot be displayed: xxxx.jpg

Configuration information

Attempts to fix:
- re-save the images in jpg with other programs - still not showing in FMP 11
- checked the file permission - all readable for every user

Workaround

none

fmp10-11_missing_image.jpeg

Outcomes