2 Replies Latest reply on Aug 26, 2014 12:50 PM by JessicaMaryott

    Remote connect with NFS network home dirs

    RobertFakes

      Summary

      Remote connect with NFS network home dirs

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      OS X 10.6

      Description of the issue

      Cannot connect to a database running on FMP 12 server from a client running FMP 12 on OS X 10.6 when using network home directories over NFS instead of AFP.

      Steps to reproduce the problem

      Mac server using NFS for it's home directories automount.

      Expected result

      To be able to connect to the db remotely.

      Actual result

      You cannot connect remotely.

      Exact text of any error message(s) that appear

      The file "Database name" could not be opened. Either the host is not available, or the file is not available on the host.

      This is after manually typing in the correct path, as the bonjour list does not populate on it's own as it does on my laptop.

      Also this is produced in the system log:


      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]: omniORB: sslContext.cc : error:02001002:system library:fopen:No such file or directory
      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]: omniORB: Assertion failed.  This indicates a bug in the application
      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]: using omniORB, or maybe in omniORB itself.
      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]:  file: /Users/alexchen/Projects/KillerRabbit/Shared/OmniORB/4.1.6/MacOS/../src/lib/omniORB/orbcore/giopStreamImpl.cc
      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]:  line: 646
      Aug 28 16:01:44 it1-spare [0x0-0x3a03a].com.filemaker.client.pro12[575]:  info: implHead == 0

      Workaround

      The only way around this for me is to

      1. Change back to AFP for network homes
      2. Change user's network home to the AFP option in Workgroup Manager.
      3. Login as user on client, start FMP 12 and it connects fine.
      4. Go back and set everything back to NFS.

      I don't want to have to do this for every user. We use NFS as it is more reliable.


      This breaks again if I go and delete the ~/Library/Application Support/FileMaker Pro/12.0/root.pem file, until I go back to AFP and it works.

        • 1. Re: Remote connect with NFS network home dirs
          PhilWortas

               This is still an issue. Unfortunately, we use an AD and need to support linux hosts so we weren't able to easily toggle the home directories over to AFP.

               If you cannot swap the mounting protocol, the following steps worked for me:

          1. Fully close the Filemaker software on the host.
          2. Create a local directory to host the 'good' config.
          3. su as the user on their machine and symlink ~/Library/Application Support/FileMaker to this local directory.
          4. Start the software and log in to the database.
          5. Close the software fully.
          6. Remove the symlink and copy the 'good' FileMaker directory to the user's networked home directory in ~/Library/Application Support/

               Just an FYI to anyone who finds this post until it is fixed.

          • 2. Re: Remote connect with NFS network home dirs
            JessicaMaryott

                 We had exactly the same problem in FM 12 and Phil's is the only solution that we found to work - thank you!