3 Replies Latest reply on Mar 27, 2010 7:43 AM by Jonny.d

    runtime can't be started in fmp 11 advanced

    Jonny.d

      Summary

      runtime can't be started in fmp 11 advanced

      Description of the issue

      I get the following error message when trying to create a  runtime solution using fmp 11 advanced, " "The primary file "DEBUG" cannot be found and is required for this application. I'm running MAC OS-X 10.62 on a Macbook Pro.I need to create a fmp runtime solution and need to know where I can get the file.

        • 1. Re: runtime can't be started in fmp 11 advanced
          TSGal

          Jonny.d:

           

          Thank you for your post.

           

          I don't see any issue on Mac in regards to the Runtime being unable to start.  I am unable to locate any issue about a "DEBUG" file.  I am able to create a Runtime solution on my Macs, including a MacBook Pro.

           

          Do you have access to another machine?  If not, try creating a new user account, log into that user account, and try creating the solution from the new user account.  Does this work?  Try uninstalling and reinstalling FileMaker Pro 11 Advanced.

           

          Any other information you can provide about your machine and/or environment may be helpful.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: runtime can't be started in fmp 11 advanced
            Steve Wright

            It sounds to me like you have either moved the file from the runtime folder or deleted it..

             

            When binding your solution, is there a file named DEBUG in the list of files to be compiled, with a red marker next to it (which makes it the primary file)

             

            The only time I can get such a message on Mac OSX is to remove my own primary database file from the runtime folder.

            • 3. Re: runtime can't be started in fmp 11 advanced
              Jonny.d

              I tried a new user, it didn't work.  I decided to read the Filemaker Help files.  That fixed everything.  The way of creating a runtime solution is very different from the last time I created a runtime solution.  My previous creations were in Filemaker 6.  The way you created a runtime in that version was by dragging or dropping the file onto the runtime engine.  That's what I did with Filemaker 11 advanced.  That's why it didn't work and I got the error message.  Instead I followed the directions for binding files into a runtime solution and all worked as expected.