AnsweredAssumed Answered

Save a Copy step don't open file (Mac OS X)

Question asked by Fred(CH) on Nov 3, 2013
Latest reply on Dec 4, 2013 by Fred(CH)

Summary

Save a Copy step don't open file (Mac OS X)

Product

FileMaker Pro

Version

11+12

Operating system version

Mac OS X 10.8.5

Description of the issue

When a script is performing a "Save a Copy As" step, where the output file isn't specified, the enduser is able to define a name, choosing a place to save, and check the option "Automatically open file". However, on Mac OS X, this option doesn't work. The file copy is saved but isn't opened. [Clone] and [Copy] were tested : same result.

If the same script is specifying an output file with the according box checked, the file is opened.
If the command of File menu is chosen instead of your script, the enduser can check the option and it works.
The second option "create an e-mail..." always works.

Steps to reproduce the problem

STEP 1
Create a brand new file with a script that perform the "Save As a Copy" step, without specifying the output file, and place a button to perform your script on a layout.

STEP 2
In Browse Mode, push your new button, define a name for the copy and a place to save, like desktop; Check the box "Automatically open file"; Push Save button.

Expected result

The file copy is saved.
The file copy is opened.

Actual result

The file copy is saved.
However, the file copy isn't opened.

Exact text of any error message(s) that appear

You don't get any error, even the script debugger is opened.

Configuration information

Mac OS X 10.8.5
iMac 27'' end 2009
2.8 GHz Intel Core i7
12 GB RAM 1067 MHz DDR3

Workaround

a ) On your script step, specify an output file with the box "automatically open file" checked.
OR
b ) Perform your script on MS Windows.

Outcomes