6 Replies Latest reply on Dec 6, 2013 9:48 AM by philmodjunk

    Save Records as PDF doesn't function

    mickthemix

      Summary

      Save Records as PDF doesn't function

      Product

      FileMaker Pro

      Version

      Pro 12.0v4

      Operating system version

      Windows

      Description of the issue

      Script step 'Save Records as PDF' causes Filemaker to crash. Under Pro 12.0v1 it functions correctly but no longer functions under v4. Appears to function correctly on a mac or if I run it on a machine still running 12.0v1.

      Steps to reproduce the problem

      Write script to export single record as PDF. Run script

      Expected result

      PDF saved to Desktop

      Actual result

      Filemaker crashes, no PDF produced

      Exact text of any error message(s) that appear

      Filemaker Pro has stopped working.
      A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

        • 1. Re: Save Records as PDF doesn't function
          TSGal

               Mick Staplehurst:

               Thank you for your post.

               I am unable to replicate the issue.  This is what I have done:

               1. Using FileMaker Pro 12.0v4 on Windows XP, I created a file with one table, one text field, and one record.

               2. I created a script "Export PDF' with the script step "Save Records as PDF" specifying the file name "TSGal.pdf" and saving to the Desktop.

               3. I execute the script, and the PDF file is created.

               4. I then performed the same steps with FileMaker Pro 12.0v4 running under Windows 7.

               Between the last time Save as PDF worked under FileMaker Pro 12.0v1 until the crash in FileMaker Pro 12.0v4, what other changes were made?  This includes the database file and/or system related changes.

               TSGal
               FileMaker, Inc.

          • 2. Re: Save Records as PDF doesn't function
            philmodjunk

                 And please note that a crash could damage your file. It's a good idea to use recover to check it for damage after a crash.

                 Things to keep in mind about Recover:

                 While Recover almost always detects and fully corrects any problems with your file...

                   
            1.           The recovered copy may behave differently even if recover reports "no problems found".
            2.      
            3.           Recover does not detect all problems
            4.      
            5.           Recover doesn't always fix all problems correctly
            6.      
            7.           Best Practice is to never put a recovered copy back into regular use or development. Instead, replace the damaged file with an undamaged back up copy if this is at all possible. You may have to save a clone of the back up copy and import all data from your recovered copy to get a working copy with the most up to date information possible.

                  

                 And here's a knowledgebase article that you may find useful: What to do when your file is corrupt (KB5421).

            • 3. Re: Save Records as PDF doesn't function
              mickthemix

                   As usual thanks to people for responding with support. However TSGal, despite what you've done I can only react to what I can see. I took a laptop from stock yesterday and installed Filemaker 12.0v1 on it from scratch. I then used that to log on to the remote solution and tried to output a PDF; it worked faultlessly!

                   I then updated Filemaker to 12.0v4 and; lo and behold it now crashes Filemaker (with as I now know a variety of messages depending on which way the wind is blowing) however all the dialog boxes say fundamentally the same thing, 'Filemaker has ceased to function'.

                   Putting pauses into the script shows that it works right up to the point where it actually tries to generate the PDF. I will try today some simple things like deleting the script and rewriting but I don't have particularly high hopes for that approach.

                   Unfortunately as to what has changed since it last worked, I don't know. Nobody can remember when it actually stopped working and therefore we cannot pin down changes since then.

                   Once again thanks to everybody for the input.

              • 4. Re: Save Records as PDF doesn't function
                philmodjunk

                     As another test, just create a small file with just a few items on a single layout. Try saving a PDF from this brand new test file. If you can save a PDF from it without crashing, this would suggest that your original file has an issue that is responsible for the crash. A damaged layout is one, not the only possible cause for such.

                • 5. Re: Save Records as PDF doesn't function
                  mickthemix

                       The database is a solution that is used both on our internal network and over a WAN by our drivers. The ability to save certain pages as PDF to distribute to drivers without iOS devices has always been important. This functionality still works on some Windows machines and on all the Macs that I have tried. I have also tried it on one of the machines that has exhibited the problem, by launching the solution as a stand-alone program locally on that machine; it works without any problem. This suggests to me that the problem lies in the interaction between PDF production and the network software? I will continue to experiment and let you know if I find a repeatable answer.

                        

                       Mickthemix

                  • 6. Re: Save Records as PDF doesn't function
                    philmodjunk

                         What you describe IS support for concluding that your file is not the issue. But it is not 100% conclusive. The Simple test that I suggested would be a better way to make sure that this is the case.

                         Here's why:

                         I've seen a number of cases where an issue with a file was not discovered until the OS version, OS platform, or FileMaker Version was changed, then what apparently was damage to the file not previously detected caused a problem such as a crash. It's not a common problem, but I have seen it happen and have had it happen to me (though many versions and years ago...).

                         Taking a back up copy down off the server and running a recover on it would also be a good idea.