7 Replies Latest reply on Jan 29, 2015 6:52 AM by nickorr

    SAXParseException

    MichaelO'Brien_1

      Summary

      SAXParseException

      Product

      FileMaker Pro

      Version

      FMP Advanced 13

      Operating system version

      OSX 10.9.5 and Windows Server 2008

      Description of the issue

      When I converted to FMP 13, I started to get the XML parsing error 3 times in a row as described in previous reports for FMP 11.  My DDR runs fine in FMP 12.  The error indicates a line and a column of 8, but there are only 7 columns in the temp file.  I can't run either an XML or HTML report.    When I run the DDR in Windows, I get a different line number than when I run it in OSX.  I've discovered that it is a layout issue specifically, but I can't locate it.  I've narrowed it down to 23 layouts, and if I delete them all, the error goes away.  I'd prefer to fix the issue rather than having to recreate these layouts.  They are all very old and haven't been edited in years, so it's perplexing why this is failing in 13 and not in 12..

      Steps to reproduce the problem

      Run an HTML DDR

      Expected result

      A Clean DDR

      Actual result

      XML Parsing error

      Exact text of any error message(s) that appear

      SAXParseException: invalid character 0x16 (Occurred in entity '/private/var/folders/mz/b_z7lgv96h9c77g6qy5f1s18lxdbwy/T/FMTEMPFM40341_44.tmp', at line 2653842, column 8.)

      Workaround

      Delete 23 layouts

      DDR_Error_OSX.png

        • 1. Re: SAXParseException
          TSGal

          Michael O'Brien:

          Thank you for your post.

          I don't expect you to count down to line 2653842 in the file.

          Keep in mind that FileMaker 13 is more strict in the XML as characters below ASCII-32 (space) cannot be interpreted and that is the reason for the SAXParseException error.  You may want to first try running the DDR with just the data, and if that work, then try the layouts.  This may help reduce the search for the character.

          Keep me updated with any progress.

          TSGal
          FileMaker, Inc.

          • 2. Re: SAXParseException
            MichaelO'Brien_1

            Hi TSGal~

            No need to count out the lines, I brought the temp file into FM.  Here is the text in that line "<Data>&#09;&#13;</Data>".  The other issue is I'm getting different line numbers depending on OS.  Here's my Windows error attached.  I'm positive that it's a layout element, but I can't determine what.  I've narrowed it down to 23 layouts which is good, because the file contains 484 layouts.  I can't outright delete the layouts, and I hate to have to re-create them, but it's likely what I'll have to do.  I rely on BaseElements pretty heavily, so I desperately need a new DDR.

            Thanks~

            Michael

            • 3. Re: SAXParseException
              MichaelO'Brien_1

              Another note...  I was systematically deleting the 23 layouts, and one of them caused the error to go away (on four separate DDR runs).  I restored my file and deleted just that layout and got the error back.  I went back to the one that "worked", and it no longer did... very mysterious!

              • 4. Re: SAXParseException
                TSGal

                Michael O'Brien:

                The data in that line is trying to display a tab character and Control-S.  In the lines preceding, does it tell you where the data occurs?  That is, what layout?  Find that object and delete it, since it doesn't appear to be doing anything.

                If you find the layout, perform a Select All to see all the objects.  You will probably see handles on an object that is blank.

                TSGal
                FileMaker, Inc.

                • 5. Re: SAXParseException
                  nickorr

                  Michael,

                   

                  It's possible to find the layout.  Go to the error and then do a find for :

                  <Layout 

                  ( that has a space on the end ), but find the previous one.  You'll eventually get to a line like :

                  <Layout width="1066" quickFind="True" includeInMenu="False" id="29" name="Artiklar_List">

                  the name is the bit in the name tag.  Delete that and you should be good to go.  I do this all the time, so if you need help, send me a copy of the XML DDR.

                  Cheers,

                  Nick

                  • 6. Re: SAXParseException
                    MichaelO'Brien_1

                    Hi Nick~

                    I did send a copy of the XML file to you not too long ago through a help request on Goya (via Google Docs), but you weren't able to help due to the size of the file.  I've created one that is layouts only (where the problem(s) are) if that would be easier to look at.  I'm not clear on how to send a file via this forum though.

                    Thanks~

                    Michael

                    • 7. Re: SAXParseException
                      nickorr

                      Michael, send me a zip, or a dropbox link if it's too big.  Contact me privately by clicking on my name and on the next screen, click "Send Nicholas Orr a Message".