2 Replies Latest reply on Dec 9, 2011 4:42 PM by PeteWellington

    Script dies on idle

    PeteWellington

      Summary

      Script dies on idle

      Product

      FileMaker Go

      Version

      1.2.3

      Operating system version

      ios 5.0 - iPad

      Description of the issue

      Because any script running will pause when the iPad goes into auto-lock, longer scripts become very difficult to manage.

      As you probably well know, running synchronisation scripts is one of the most effective ways of enabling a user to roam within patchy network connections but still manage to keep records centralised.

      We cannot expect our users to keep touching the screen to stop it from auto-locking, and due to security concerns we must have our iPads set to auto-lock after inactivity. On ios the longest period that this can be (other than never) is 5 minutes.

      I believe that if filemaker go were to utilise either of the following methods before running any script then this would alleviate the issue, the second option is the more robust as it would allow a script to keep running while a user switches to another app, but it does require ios >v 4. the first option should work for ios>v 2.

      idleTimerDisabled;
      http://developer.apple.com/library/ios/#DOCUMENTATION/UIKit/Reference/UIApplication_Class/Reference/Reference.html#//apple_ref/doc/uid/TP40006728-CH3-SW57

      beginBackgroundTaskWithExpirationHandler:
      http://developer.apple.com/library/ios/DOCUMENTATION/UIKit/Reference/UIApplication_Class/Reference/Reference.html#//apple_ref/doc/uid/TP40006728-CH3-SW79

      Steps to reproduce the problem

      run any script that will take some time to complete, either hit the lock button or wait for auto-lock to kick in (assuming it is enabled)

      Expected result

      Scripts should be able to either run in background or switch of the idle timer before running.

      Actual result

      Scripts pause as soon as the auto-lock takes effect.

      Workaround

      None