4 Replies Latest reply on Jun 26, 2013 6:56 AM by jrobgk1

    Script problem - Send Email using client (Outlook)

    philhargreaves

      Summary

      Script problem - Send Email using client (Outlook)

      Description of the issue

      FileMaker Pro v11(Trial) on Windows 7 I am getting 'Unknown Error -1' pop up every time I use a script step to send an email, with attachment, via my email client (Outllok 2003). The same scripts work fine on earlier versions (FMP 9 & 10). Sending mail via SMTP works flawlessly but we do not want to adopt this method; we like being able to see our sent items. I am only using the trial version whilst I assess the options of upgrading multiple users - maybe this email problem has been resolved in the retail release? 

        • 1. Re: Script problem - Send Email using client (Outlook)
          TSGal

          PhilHargreaves:

           

          Thank you for your post.

           

          The trial version and the general release version are identical, except the trial version is limited to 30 days.

           

          I do not have Outlook on the Windows 7 machine, so I am unable to replicate the problem using FileMaker Pro 10 and FileMaker Pro 11.  I had difficulty trying to install FileMaker Pro 9 on Windows 7.

           

          Does the script step work with an attachment?

           

          Is it all emails with an attachment, or just some emails?  If the latter, what is the name of the attachment?  Are you using a different language OS?

           

          Any other information you can provide may be helpful.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Script problem - Send Email using client (Outlook)
            philhargreaves

            Hi,

            Thanks for your response.

            It makes no difference if there is an attachment or not.

            To test it further, I created a new empty database file and added a simple button to activate the 'Send Mail [Send via E-mail Client]' function - I still get the same result, ie. "Unknown Error: -1."

            If I open the file with FileMaker Pro 10, the button works fine - a blank email window opens.

            I'm running Windows 7 Ultimate 64 bit version, Outlook 2003.

             

            I just had a thought while writing - I just tried running FileMaker Pro 11 'as administrator' and it works fine, problem solved.

             

            Sorry to waste your time.

            • 3. Re: Script problem - Send Email using client (Outlook)
              TSGal

              PhilHargreaves:

               

              I'm glad you were able to solve the problem.

               

              Please don't apologize for "wasting" my time!  Others may run into this same problem, so your solution may help others.

               

              TSGal

              FileMaker, Inc.

              • 4. Re: Script problem - Send Email using client (Outlook)
                jrobgk1

                     what if we don't have the option of running someone as an administrator? this is a bug that still haunts my users, and there is no fix out there?