AnsweredAssumed Answered

Script Step "Send Mail" ; Send via: E-mail Client ; Apple Mail - address calc problem

Question asked by brett on Oct 13, 2011
Latest reply on May 9, 2013 by dbrockman

Summary

Script Step "Send Mail" ; Send via: E-mail Client ; Apple Mail - address calc problem

Product

FileMaker Pro

Version

FMP  & FMP Advanced 11.0v3

Operating system version

Mac OS X 10.5 & 10.6

Description of the issue

Using the Script Step "Send Mail" ; Send via: E-mail Client ; Apple Mail.
I have discovered the following problem.

In FMP 10 this script worked just fine. However in FMP 11 the To: field in the resulting email messages have only the email address without the Name. In FMP 10 and using the same various versions of Apple Mail, the To: address would look like this:

Joe Blow

Using FMP 11 (and the same Apple Mail program) we get:

jblow@domain.com

Steps to reproduce the problem

As above, create a script with Send Mail and concatenate a name & and email address.

I have written the calculation many different ways and though they all work in the Data Viewer in FMP 11, the resulting email message address has only the email address without the name or the " <" or the ">" .

I also tried putting the calculations into a variable and using that in the Send Mail "To:" field. Still no joy!

Some to the code that I used;

TableOccurence::Full name & " <" & TableOccurence::Email & ">"

TableOccurence::Full name & GetAsText ( " <" )  & TableOccurence::Email & GetAsText ( ">" )

TableOccurence::Full name & " " & Char ( 60 )  & TableOccurence::Email & Char ( 62 )

Quote ( TableOccurence::Full name ) & " " & Char ( 60 )  & TableOccurence::Email & Char ( 62 )

[As I said, with everything else being equal, including the Apple Mail program, this works in FMP 10]

Interestingly, if I try to escape the the < > characters with a back slash like this;
TableOccurence::Full name & " \<" & TableOccurence::Email & "\>"

The result in Apple Mail looks like this;
Joe Blow \

One more thing; I fired up venerable Eudora and it works with Eudora and FMP 11 just as it did with FMP 10 !

Expected result

Joe Blow

Actual result

jblow@domain.com

Exact text of any error message(s) that appear

No error message

Configuration information

This performs the same when run as a local file or on FMPS 10 using the 10 & 11 clients as described above.

Workaround

Haven't found anything yet other than going back to FMP 10 and not upgrading the Server to 11 which I was just about to do.

Outcomes