AnsweredAssumed Answered

Script step "Speak" does not use specified voice

Question asked by ahendin on Aug 6, 2010
Latest reply on May 22, 2015 by ontarget

Summary

Script step "Speak" does not use specified voice

Product

FileMaker Pro

Version

10 Advanced v3

Operating system version

Mac OS X 10.5.8

Description of the issue

"Speak" includes a "use voice" option. It is ignored when the "Wait for speech completion before continuing" option is UNchecked, and the system default voice is used instead.

Steps to reproduce the problem

Create a script with one step, "Speak". Specify text to speak, and set the Use Voice droplist to a voice other than the system default. UNCHECK the "Wait for speech completion before continuing" option.

Click OK, then save and run the script.

Expected result

Text spoken in the specified voice.

Actual result

Text spoken in system default voice.

Exact text of any error message(s) that appear

None.

Workaround

If you want FileMaker to speak in the specified voice, you must CHECK the "Wait for speech completion before continuing" box.

Outcomes