0 Replies Latest reply on Oct 14, 2012 2:33 PM by StevenKienle

    Scripts Not Executing in Preview Mode

    StevenKienle

      Summary

      Scripts Not Executing in Preview Mode

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac OS X Lion

      Description of the issue

      I have a layout set up that using both the OnLayoutEnter and OnLayoutExit script triggers.  The first to set the necessary find criteria for the report then to enter Preview mode.  The second to reenter Browse mode.  But when in Preview mode, neither of these scripts appear to be triggered, even through the OnLayoutExit documentation specifically states "Modes in which the trigger can be used: Browse, Find, and Preview modes."

      Am I misreading the documentation and as long as I am in preview mode the scripts are not executed, is this a bug or is there some option I need to set which I haven't?

      Thanks,
           Steve

      Steps to reproduce the problem

      Create a script with a Pause Script step
      Set it to the OnLayoutEnter or OnLayoutExit mode
      Switch to another layout and enter Preview Mode
      Switch to this layout

      Expected result

      The script should be executed

      Actual result

      The script does not execute

      Exact text of any error message(s) that appear

      No error message appears, the script simple does not execute.

      Workaround

      Other that having the user manual exit preview before switching layouts, none