AnsweredAssumed Answered

send email via SMTP will not accept global variable for address on remote databases

Question asked by psijmons on Dec 13, 2010
Latest reply on Jan 25, 2011 by psijmons

Summary

send email via SMTP will not accept global variable for address on remote databases

Product

FileMaker Pro

Version

FMPA v11.2

Operating system version

OSX10.6.5

Description of the issue

When trying to send an email via server-SMTP and enter the email address via a $Email global variable, it will not process the emai but returns an error 1506.

This works well on a local testserver, but when the databases are hosted remotely it fails.
Only when I set this param in a field first, then use that field to populate the To: field, it works on the remote machine.

All other parts (CC, subject, body) will work from global variables, it is only the email address where this fails.

Steps to reproduce the problem

Using similar script steps where the To: field is hardcoded or where the To; field is coming from a table field.

When a variable comes in from a script param and is set as $ variable, the problem occurs. With debugger I can see the $var is correct and gives a correct email address but it simply fails with error 1506.

Expected result

It should accept a global var

Actual result

error 1506 when database is remote

Exact text of any error message(s) that appear

1506

Configuration information

Local testserver means FMSA (11.02.217) is running on the same machine as FMPA11.0.2
Remote server means FMSA (10.0.2.206) on remote hosted db with FMPA11.0.2 as client
(SMPT-server sending is a FMS10 feature, right?)

Workaround

Added a field to enter the email address and use field contents to fill the email settings.

See image for different options tested:
option 1 will fail
option 2 will work
option 3 will work

Edit_Script__process_email_via_SMTP_server_%5BMSP%5D_To-Subj-CC-Body__%28WelcomeViewer%29.jpg

Outcomes