1 Reply Latest reply on Oct 28, 2013 10:27 AM by jgalt

    Send Mail inserts random carriage returns when there's a funny apostrophe character

    hi-voltage

      Summary

      Send Mail inserts random carriage returns when there's a funny apostrophe character

      Product

      FileMaker Pro

      Version

      12v3

      Operating system version

      10.7.5

      Description of the issue

      When there's a funny apostrophe character inserted into the body of the email, Send Mail inserts random carriage returns throughout the email.

      The funny character usually comes in via a copy paste from other applications such as MS-Word, and impossible to detect with the eye.

      Tested this issue in FM11 and works perfectly fine, but does not work correctly in FM12.


      NOTE: I have provided a screen shot which demonstrates the problem, but the problem doesn't look too bad in my example - with real text and lots of paragraphs the problem is quite severe.

      Steps to reproduce the problem

      Create a new field, insert some text with multiple paragraphs. Make sure there's a funny apostrophe in the text somewhere (anywhere will do).

      Here's one: ’    (ASCI CODE 8217)

      Create new script, use Send Mail, use the new field as the email body. Send email.

      Expected result

      I expect the email to send correctly, with the carriage returns in their correct places.

      Actual result

      Carriage returns are inserted in random places within the email.

      Configuration information

      Using Entourage 2008 - don;t think this is the problem because it works fine in FM11 and does not work properly in FM12.

      Workaround

      Replace the strange character via a calculation - HOWEVER, then NO carriage returns get inserted at all, not even where they should be. I've already submitted a bug report for this secondary issue where no carriage returns get inserted at all.

      image.gif