AnsweredAssumed Answered

Send Mail not working in Webdirect

Question asked by sjamesbj on May 15, 2014
Latest reply on Feb 13, 2015 by TSGal

Summary

Send Mail not working in Webdirect

Product

FileMaker Server

Version

13.0.2.295

Operating system version

Windows Server 2008 R2 w/SP1

Description of the issue

Send Mail script step not generating email in Webdirect. Have tried in Internet Explorer 10 and Google Chrome v34.x. Running Windows 7 Professional and Outlook 2010. Script used to work prior to Heartbleed update. Tried installing latest update to server to fix the problem, still no email. Script step is NOT marked "Perform without dialog". Script IS marked "Run script with full access privileges".

Remainder of script works as if email was sent. Pop-ups are not blocked on either browser. Google Chrome does have a new window open (see screenshot), however it is a browser window, not email.

Outlook has been set as the default mail program and is the default handler for the mailto protocol.

Steps to reproduce the problem

Have tried it on two different PCs. Both are Windows 7 Professional. Restarted the PCs, same problem. Different user logged in, same problem. Updated FMS to 13v2, same problem.

Here is the script in question:

Set Error Capture [On]
Send Mail[Send via E-mail Client; To:email@test.com; CC:email@test.com; etc. etc.
If[Get( LastError )]
ExitScript[Result:"EMAIL NOT SENT"]
Else
SetField[audit_SubmitStamp; TimeStamp(Get(CurrentDate);Get(CurrentTime))]
EndIf
CommitRecords/Requests[No dialog;Force Commit]

Expected result

Send Mail script step should open an Outlook email message window and user clicks on Send.

Actual result

Nothing from Internet Explorer 10. Google Chrome opens another browser window with the mailto information in the address bar.

Exact text of any error message(s) that appear

No error messages. Remainder of script runs as if there was no problem.

Configuration information

Server is Windows Server 2008 R2 w/SP1, FileMaker Server is v 13.0.2.295. Intel Xeon Processor, 2 cores, 7.81 GB RAM, 80 GB free on C, 102 GB free on E (Databases are house here).

PC are running Windows 7 Professional with 2 to 8 GB of RAM. FileMaker Pro 13 is installed on one and FileMaker Pro Advanced 13 is installed on the other. Since this is a problem with WebDirect, the browsers installed are Internet Explorer 10 and Google Chrome v 34.x and both PCs have Outlook 2010 installed as there only mail client.

Workaround

None.

Chrome_Result.png

Outcomes