0 Replies Latest reply on Jun 22, 2012 9:13 AM by ahcho

    Send Mail using SMTP oddity

    ahcho

      Summary

      Send Mail using SMTP oddity

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      OS X Lion

      Description of the issue

      I am trying to use the Send Mail function to send an Email (surprise! surprise) using an SMTP connection.

      Now in the message, I have the following text:

      "Hello!¶"& "Here is information"

      Running the function, I get an email with that message. However, when I change the text to:

      "Hello!¶"& "Here is information " (all I've added is a space after information)

      Running the function, I don't get an email. If I remove the space after information, then it works.

      Placing the text into a show custom dialog works for both cases.

      Steps to reproduce the problem

      1. Create a button with the Send Mail with SMTP function (I am using the outgoing mail settings for iCloud).
      2. Enter in Email
      3. In the message field, paste "Hello!¶"& "Here is information "
      4. Save and press the button

      Expected result

      I would expect to receive an email with the text "Hello!¶"& "Here is information " in the body of the email.

      Actual result

      I receive no emails. If I change the body to "Hello!¶"& "Here is information" (all I have done is remove the space after the word information, the function works.

      Exact text of any error message(s) that appear

      None.

      Configuration information

      Nothing special, no additional plug-ins

      Workaround

      None