AnsweredAssumed Answered

Serious bug when renaming a field. Field name does not change inside Let function.

Question asked by kluchnik on Nov 30, 2011
Latest reply on May 10, 2016 by Vincent_L

Summary

Serious bug when renaming a field. Field name does not change inside Let function.

Product

FileMaker Pro

Version

11.0v4

Operating system version

Mac OS X 10.7.2

Description of the issue

I have encountered a very serious bug inside the Let function. I don't know that this is limited to the let function but this is the only place I have encountered it so far.

I used a text field inside a calculation field which has a let function. In this function a variable is defined with the text field. Subsequently, I renamed the text field but it did not change inside the let function as it should have.

Steps to reproduce the problem

I have set variables inside the Let function as follows:

Let (

[
~SecMas =

If (

     checkBBTicker = "Exists" or
     checkISINNoSecCurrency = "Exists" or
     checkSecurityNameSecCurrency = "Exists" ;

     "Exists"

     ) ;

~SecMasULS =

If (

     checkBBTickerULS = "Exists" or
     checkISINNoSecCurrencyULS = "Exists" or
     checkSecurityNameSecCurrencyULS = "Exists" ;

     "Exists"

     )

] ;

As you can see, in the 1st variable there is an if statement which uses the field checkBBTicker.

I subsequently renamed that field to checkBBID.

Expected result

Upon renaming the field, the field should have also changed inside the let function.

Actual result

What actually happened is the field remained with the old name. However, if I open the calculation field with the let function, and then tried to click OK, it gives me the error that that field name does not exist. However, if I click cancel, it allows the fields to remain.

Configuration information

In order to test this, I changed the name of the field inside the let function to the correct name. This was accepted. Then I went and changed the original fields name again, and again it did not change inside the left function.

I tried creating a new calculation field with a let function inside but could not reproduce this error. This error happens only in the original let function. I then duplicated the calculation field and did the changes in the new field. Here the error was reproduced.

Workaround

This is not really a workaround, but I have done some further testing and it seems that it has something to do with the field being inside an IF function. If I change it to read

~SecMas = checkBBTicker

And then change checkBBTicker field to checkBBID, then it changes to

~SecMas = checkBBID

But as long as there is an IF statement, even a simple one like:

~SecMas = If ( checkBBTicker = 1; 1 ; 0 ) then it does not change when the original field is changed.

Bug_in_Filemaker.png

Outcomes