1 Reply Latest reply on Jan 31, 2013 10:41 PM by mrjamesmoore

    Server 12 backup aborted due to remote container copy error

    mrjamesmoore

      Summary

      Server 12 backup aborted due to remote container copy error

      Product

      FileMaker Server

      Version

      12.0.3

      Operating system version

      Windows Server 2008 RC2 Standard SP1

      Description of the issue

      I'm using the FM12 remote container (RC's) feature in a solution that consists of 5 files. 1 file is the main file containing 95% of the infrastructure and there are 4 other ancillary files. I have a daily scheduled backup that backs up all 5 files and recently noticed the main file was not included in the backup.

      Upon investigation I found out the issue was the backup was aborting due to a remote storage error; some of the files could not be backed up (copied). The error is contained in the email sent by the server.

      Steps to reproduce the problem

      Create a backup schedule which contains my all my files and run it.

      Expected result

      - Backup of FileMaker files completes even if RC's can't be copied. Why does the backup of the FileMaker file stop if the RC's can't be copied?
      - Schedule Status to NOT say OK if it didn't work.
      - Some explanation telling me why the RC's couldn't be copied if they fail

      Actual result

      - Backup of FileMaker file aborted
      - Status of backup says "OK" - it's not - it didn't work.

      Exact text of any error message(s) that appear

      2012-12-28 16:00:09.504 +1100     Error     766     SG FMSv12     Backup of "<>" aborted; error (-1) creating remote container folder "filewin:/C:/Program Files/FileMaker/FileMaker Server/Data/Backups/Hourly/Hourly_2012-12-28_1600/Databases/<>/RC_Data_FMS/<>/Images/<>".

      Workaround

      When I create a schedule backup with JUST this main file included I get the same error but the FileMaker file IS backed up. Why does the file fail to backup when it's part of a set but work when it's on its own?

        • 1. Re: Server 12 backup aborted due to remote container copy error
          mrjamesmoore

               Thanks to FM Support this has been resolved.

               The issue was the folder structure for the RC Data contained invalid characters for the backup routine, such as commas. Although these characters are valid for the OS they're not for the backup.

               I updated the container field using the filter command to remove non alphanumeric charcters and that triggered FM to transfer the data. After that the backups worked as expected.

               The strange behaviour of FMS when a backup fails is still a mystery. The first time the FM file would be backed up but subsequent attempts would fail, unless I changed the backup to another folder, and then again the first one would work only. The fact the Schedule status says 'OK' even when the backup failed is wierd.