1 Reply Latest reply on Sep 14, 2012 9:58 AM by disabled_ntaylor

    Set Variable [$$uLogin: Value:Get ( AccountName )]

    gwinzeler

      Summary

      Set Variable [$$uLogin: Value:Get ( AccountName )]

      Product

      FileMaker Server

      Version

      FMA 12 v2

      Operating system version

      iOS

      Description of the issue

      Using like this in startup file:

      Set Variable [$$uLogin: Value:Get ( AccountName )]

      Further testing has found this:

      works fine when Server is set to default under - Configuration - Database Server - File Display Filter - List all databases

      switch to - List only the databases each user is autorized to access - and you get the incorrect account names (not the ones typed in when logging into file)

      Steps to reproduce the problem

      works fine when Server is set to default under - Configuration - Database Server - File Display Filter - List all databases

      switch to - List only the databases each user is autorized to access - and you get the incorrect account names (not the ones typed in when logging into file)

      Workaround

      set to default setting

        • 1. Re: Set Variable [$$uLogin: Value:Get ( AccountName )]

               Gary Winzeler:

               Thank you for the post. 

                

               Does the person logging in to the database log in twice? The first login should be for accessing the files on the server and the second login to access the actual database file?

                

               Here are the steps I took to attempt to replicate:

                

               1. File>New Database

               2. Set a script trigger “OnFirstWindowOpen” to run the following Script:

                

                           Set Variable {$$uLogin; Value:Get (AccountName)]

               Refresh Widow [Flush cached join results; Flush cached external data]

                

               3. Create a second full access admin account named “TEST” with password “test.”

               4. Placed a merge variable on the only layout: <<uLogin>>

               5. In the FileMaker Admin Console: Configuration - Database Server - File Display Filter – List only the databases each user is    

                    authorized to access

               6. Login through FileMaker Pro/FileMaker Go to the server. TEST file displays.

               7. Login to the TEST file with the password.

               8. My merge variable displays TEST.

                

               By default, the File>Options were still set to auto-login to the main “Admin” account, but once the “Log in using:” box was unchecked, the merge variable displays the correct account.

                

               Please let me know if I am missing a step to replicate.

                

               TSFalcon

               FileMaker, Inc.