1 Reply Latest reply on May 15, 2012 7:18 AM by TSGal

    Show/Hide Formatting Toolbar Button Grayed out when using Custom Menus in FM 10 or 11

    dataapex

      Summary

      Show/Hide Formatting Toolbar Button Grayed out when using Custom Menus in FM 10 or 11

      Description of the issue

      FileMaker Product(s) involved:FileMaker Pro Adv 10.0v3, FileMaker Pro Adv 11.0v1, Operating System(s) involved:Windows XP Detailed description of the issue:When a custom menu set in a database that was created with an earlier version of FileMaker ( FM 7 in this case ) is active the Formatting Toolbar Button is grayed out.   In FM Adv if you change back to the default Menu set the problem is instantly resolved.  Select the Custom Menu set and the problem comes back. Exact steps to reproduce the issue:1. Open a database that was created with FM Pro 9 2. In FM Pro Advanced 10/11 change the Menu set to the default "Customer Menu Set" or any other menu set Expected Result:The "Show or Hide the Formatting Bar" but should stay clickable Actual Result:The "Show or Hide the Formatting Bar" grays outExact text of any error message(s) that appeared:N/AAny additional configuration information/troubleshooting that is relevant to the issue:1.  I have verified that databases created from scratch in FM 10/11 do not exhibit this same problem. 2. Doesn't seem to be related to any specific custom menu item, but custom menus in general. Any workarounds that you have found:I have not found any.

        • 1. Re: Show/Hide Formatting Toolbar Button Grayed out when using Custom Menus in FM 10 or 11
          TSGal

          Dataapex:

          Thank you for your post.

          The Formatting Bar was not a menu option in FileMaker Pro 9 and earlier.  In the Custom Menu set, you will need to add it.  That is, using FileMaker Pro 10/11 Advanced, pull down the Tools menu and select "Custom Menus -> Manage Custom Menus...".  In the Manage Custom Menus window, select the "Custom Menu Sets" tab, and select the Custom menu set you want to modify.  Click "Edit...".  In the "Edit Custom Menu Set" window, click the "View Copy" and click "Edit...".  In the bottom left corner of the "Edit Custom Menu" window, click "Create", and in the listing of Menu Items above, the last entry is "<unknown>" and it will be highlighted.  On the right side, the pop-up next to "Menu Item Type" should display "Command".  If not, change it to "Command".  Just below that, click the checkbox for "Based on existing command".  In the "Specify FileMaker Command" window that follows, scroll down, click "Formatting Bar" and click OK.  That window will close and put you back at the "Edit Custom Menu" window.  Move "Formatting Bar" up to where you want it to appear, and then click OK.  Click OK again to exit the "Edit Custom Menu Set" window, and click OK again to exit the "Manage Custom Menus" window.

          Let me know if you need additional clarification.

          TSGal
          FileMaker, Inc.