7 Replies Latest reply on Oct 20, 2013 2:41 AM by Fred(CH)

    Signature Container Showing Black on View

    didigygroup

      Summary

      Signature Container Showing Black on View

      Product

      FileMaker Go

      Version

      Latest

      Operating system version

      iPad 3

      Description of the issue

      We are using a Container field for a Signature which shows a completely black screen when using the Action / View on an iPad 3.

      Steps to reproduce the problem

      1. The small thumbnail shows correctly.
      2. When you try to view it using an iPad 3 you get a completely black screen.
      3. If you export the content when viewing as per #2 the .png file is completely black.
      4. If you export the content of the Container field from a PC the image is correct.
      5. If you replace it with a camera shot or imported picture it views normally on the iPad.

      Expected result

      View an enlarged version of the signature.

      Actual result

      Black screen

      Exact text of any error message(s) that appear

      None

      Workaround

      No Workaround

        • 1. Re: Signature Container Showing Black on View

               Graeme McGeorge:

               Thank you for your post.

                

               This issue was previously reported. I went ahead and forwarded your research to our Development and Testing departments.

                

               TSFalcon

               FileMaker, Inc.

          • 2. Re: Signature Container Showing Black on View
            philmodjunk

                 Is this only on the iPad 3 or do other iOS devices have this issue?

            • 3. Re: Signature Container Showing Black on View

                   @PhilModJunk:

                   Thank you for the reply.

                   I'm getting mixed results in my tests. On an iPhone 4 running iOS 5.1.1, I was able to see the signature. On an iPhone 4S with iOS 6.0.1 or an iPad (3rd Generation) with iOS 6.1, I saw only a blank black background. 

                   TSFalcon

                   FileMaker, Inc.

              • 4. Re: Signature Container Showing Black on View
                philmodjunk

                     Going only by what you have in your last post, would it be reasonable to say that the common denominator was the iOS version 6.0.1?

                • 5. Re: Signature Container Showing Black on View
                  apmiller

                       Not limited to iOs 6.0.1 or iPad 3. I had the same result (signatures, which are .png files, always "View" as an all black screen, but can be exported to the camera roll, or other Apps capable of viewing a png file) with my iPad 1, with ealier OS versions, since the onset of of original FileMaker Go. I keep expecting FileMaker to notice and fix this issue. I now have a iPad 4, F.P. 12, & latest FileMaker Go. I haven't tried on an iPhone. (OS X 10.7.5)

                  • 6. Re: Signature Container Showing Black on View
                    philmodjunk

                         Thanks! now updating this report link accordingly.

                    • 7. Re: Signature Container Showing Black on View
                      Fred(CH)

                           Hi all,

                           I went here today because this problem was recently reported on the FTN french FMGo forum and i tried to help folks.

                           Firstly, I was surprised to find this one, an acknowledged bug on FM Go, one year later, since FMI is so dynamic to fix his FMGo bugs... And i was wondering "how can this bug live so longtime through FMGo and iOS versions ?".

                           After a little investigation, i think i found a bit of explanation :

                             
                      1.           The iOS visualizer have black background
                      2.      
                      3.           FMGo is generating a PNG with transparency where the signature is black and without any background.
                      4.      
                      5.           Black over Black result Black

                            

                           I then tried to export my field content to the Mac Desktop, and with Apple Preview passed from PNG to JPEG, thus a white background was automatically added. And then, inserted this JPEG version instead of the original PNG and, of course, the display command worked.

                           To be sure, i also re-inserted back the original PNG file from the desktop to the field and the issue was back.

                           Hope this helps...

                           Bye, Fred