2 Replies Latest reply on Oct 9, 2012 11:46 AM by jarobinson

    Sliding / Resizing cuases both field data, and static text to fail to print.

    jarobinson

      Summary

      Sliding / Resizing cuases both field data, and static text to fail to print.

      Product

      FileMaker Pro

      Version

      FileMaker Pro Advanced 12.0v2 / FileMaker Pro 12.0v2 / FileMaker Server Advanced

      Operating system version

      Windows & Mac

      Description of the issue

      Both field data and static textbox text not printing. Have tried adding a blank field, adding a footer, trailing footer, allowing additional length to fields and layout, etc. sometimes it helps, sometimes it doesn't. Is there a work around available for the sliding / resizing of fields and parts?

      Steps to reproduce the problem

      Create a layout in FileMaker Pro 12.0v2 Advanced, Share via FileMaker Pro Server 12 Advanced, access via FileMaker Pro 12 Advanced or FileMaker Pro 12.0v2. Layout should contain multiple fields of large size set to "Sliding up based on: All objects above" and "Also resize enclosing part". Text fields should be separated a one or two line textbox of static text for headings along with a line object. These should be set to slide up based on all objects above and also resize enclosing part. Should have a line and a textbox after the last field, also set to slide up and resize enclosing part. Footer / no footer both tried with a blank field enclosed which effect how much prints, but doesn't fully rectify the issues.

      Expected result

      All text field data should print since the field size on layout is larger than text contained. Static text should fully print since the text box is as large or larger than the text it contains. All should fit since the layout is set to be upto 6 pages long. Printed report is only 3 pages after being resized.

      Actual result

      Text in last text field is being truncated and not fully printed. No sign of line or static text box at bottom of report attempting to print at all.

      Exact text of any error message(s) that appear

      No error message returned.

      Configuration information

      This is being seen on both Windows Vista SP2, and Windows 7 64 bit systems. Being seen with various printers and print drivers, or seems to be FileMaker Specific, not printer or print driver related. Seeing same result wether using a print script or selecting print from the File Menu.

      Workaround

      Sometimes adding a blank field and/or footer will help, sometimes it does not. Removing layout theme formating sometimes helps, but have faild to find a consistant work around.