3 Replies Latest reply on Apr 14, 2014 9:45 AM by philmodjunk

    Sliding not honored when object is hidden

    PhilipZack

      Summary

      Sliding not honored when object is hidden

      Product

      FileMaker Pro

      Version

      13

      Operating system version

      OS X 10.9.2

      Description of the issue

      If a grouped object is set to slide up during preview and shorten the enclosing part, when it is conditionally hidden, the space it had taken up is not closed when viewed in preview.

      Expected result

      The hidden grouped object does not retain the full-size space it had taken up before sliding. Instead, the layout acts as if the object takes up no vertical space at all.

      Actual result

      A big empty space where the 'hidden' object had been.

        • 1. Re: Sliding not honored when object is hidden
          RickWhitelaw

               Not at a computer at the moment, but a hidden object still exists and takes up space. If you view your layout in Layout Mode you will see the hidden object.

          • 2. Re: Sliding not honored when object is hidden
            PhilipZack

                 Oh it takes up space all right. When it's showing, it closes up the section in preview, but when it's hidden it doesn't. The object in question is a grouped portal and its column headings. I was hoping that when there was nothing in the portal, I could make the report much neater by disappearing the headings and the portal entirely and have the space tightened up with the sliding directives. Perhaps in another update.

            • 3. Re: Sliding not honored when object is hidden
              philmodjunk

                   I assume that you mean hidden via the "hide object when" setting on the inspector's data tab.

                   I cannot reproduce this in Windows 7. (Don't have a mac to test.)

                   I put three fields and their label text on a layout. I selected Fields 2 and 3 plus their label text and grouped them.

                   With them still selected, I entered True into the Hide Object When box and selected "slide up" and "resize enclosing part".

                   The attached screen shots show layout mode on the left and preview mode on the right. The body has been resized to eliminate the space occupied by the hidden objects in the right hand image.