10 Replies Latest reply on May 5, 2009 11:49 AM by hschlossberg

    Slow Typing Filemaker Pro 10

    erwinthos

      Summary

      Slow Typing Filemaker Pro 10

      Description of the issue

      I use Filemaker Pro 10.0v1 and am running Mac OS X 10.5.6 to access my database which is running on Filemaker Server version 10. The server is hosted by a Mac running Mac OS X 10.4.11.  There are no more than 10 persons connected to the server at any one time.In my database I have a very large field into which I keep a running log of all activity that occurs with reference to my clients. I have found Filemaker 10 to be unusable in the sense that typing is delayed and often I have to wait 10 seconds or more to have the words that I have typed appear in the field. The secretaries in my office have gone back to Filemaker 9. I have created a work around where I type into a separate field and then use a script to paste the text into the field where it belongs but this is cumbersome and it does not seem that I should have to do this. Is there a solution to my problem?  

        • 1. Re: Slow Typing Filemaker Pro 10
          TSDiva
            

          Do you have visual spell-checking turned on? This may be causing the performance issues. If so, try disabling this option for the field and see if the performance improves.

           

          To disable spell checking for this field: 

          1. In Layout mode, select the field. 

          2. Choose Format menu > Field/Control > Behavior. 

          3. In the Field Behavior dialog box, select Do not apply visual spell-checking. 

          4. Click OK. 

           

          Please let us know if this is related. 

           

          -TSDiva

          FileMaker, Inc. 

          • 2. Re: Slow Typing Filemaker Pro 10
            erwinthos
               I did turn off visual spell-checking for the affected field. There is still a delay but not nearly as long a one. Any other ideas? There is no problem at all with Filemaker Pro 9. 
            • 3. Re: Slow Typing Filemaker Pro 10
              TSDiva
                

              Well, it sounds like you partially resolved the issue. The only other cause of performance issues in FileMaker Pro 10 that I am aware of is if you are using auto-complete on this field.

               

              To set up a field to auto-complete during data entry: 

              1. In Layout mode, double click the field, or select the field and choose Format menu > Field/ 

              Control > Setup. 

              2. Make sure 'Auto-complete using previously entered values' is not selected.  

               

              -TSDiva

              FileMaker, Inc. 

              • 4. Re: Slow Typing Filemaker Pro 10
                erwinthos
                   Auto complete was not selected. The improvement by turning off visual spell-checking was minimal and does not render version 10 workable. 
                • 5. Re: Slow Typing Filemaker Pro 10
                  TSDiva
                    

                  After further investigation this sounds like the same issue discussed in the following forum thread:

                   

                  http://fm.lithium.com/fm/board/message?board.id=aut&message.id=377

                   

                  <!--  StartFragment  -->

                  This issue seems to be more noticeable when there are minimal spaces in the text (no carriage returns) and visual spell checking or auto-complete is enabled.

                   

                  This issue is currently being investigated and we have no further information at this time. I apologize for any inconvenience that this issue is causing you.

                   

                  -TSDiva

                  FileMaker, Inc. 

                  • 6. Re: Slow Typing Filemaker Pro 10
                    philmodjunk
                      

                    With all respect to TSDiva, if auto-complete is not enabled, spell check has been disabled and typing is STILL slow, this may be a different problem as it no longer matches the report you quote.

                     

                    Some basic diagnostic questions to help everyone out:

                     

                    Can you duplicate this problem with a completely new file/completely new field? If not, then there may be a problem with your file, try recovering it or replacing it with a backed up copy.

                     

                    How large is your text field? 10 -50 characters? 100's? 1000's?

                     

                    • 7. Re: Slow Typing Filemaker Pro 10
                      mrvodka
                         Do you have indexing on for this field? If so, try reindexing it to see if it helps.
                      • 8. Re: Slow Typing Filemaker Pro 10
                        TSDiva
                          

                        I apologize if my last post was confusing. You do not have to have visual spell checking or auto-complete enabled to experience the performance issue, these options just add to the problem. The problem is most apparent when there are minimal spaces in the text (no carriage returns) but again this is not necessary.

                         

                        According to our findings there is no perceivable difference in performance between FileMaker Pro 9 and FileMaker Pro 10 until ~1,000 lines of text. After that the difference slowly becomes bigger as the number of lines increases. The performance may very depending on the text (style, Asian fonts, ect).

                         

                        -TSDiva,

                        FileMaker, Inc. 

                        • 9. Re: Slow Typing Filemaker Pro 10
                          erwinthos
                            

                          I did as you suggested and determined that the field was not being indexed. However, auto look up was chosen. I do not know why. I turned off auto look up and the typing delay has greatly improved. I have not tested the field extensively but am optimistic. Thanks for the clue.

                          Incidentally, the filed can have up about 6 pages of type written text in it. 

                          • 10. Re: Slow Typing Filemaker Pro 10
                            hschlossberg
                               Do you have any strcipt triggers attached to the problem field?