1 Reply Latest reply on Jul 12, 2012 7:22 PM by tduell_1

    SMTP Error 1506 on Windows XP SP3

    tduell_1

      Summary

      SMTP Error 1506 on Windows XP SP3

      Product

      FileMaker Pro

      Version

      12.0

      Operating system version

      Windows XP SP 3

      Description of the issue

      We are able to use our test file on OS X to send SMTP using the Send Mail script step just fine. When we run the same exact file and script from a Windows XP SP 3 box we receive the universal 1506 error message that tells us nothing about why it refuses to send. We are aware of malformed header problems dating all the way back to FileMaker 10 days (several years now). That's why we switched to SMTPit and an external generic Yahoo email account for Windows users. Now that we are on FileMaker Server 12 we are re-investigating using the built in Send Mail script for full server-based automation. However, we are still having the same problems sending SMTP email on Windows only. Why the Send Mail script using the SMTP server settings would work on OS X and not Windows is completely baffling!

      Steps to reproduce the problem

      1. Yes, we even tried the trick to remove the user name and only send the email address. That did not make a difference. It still produced the 1506 error.

      2. Our SMTP setting as as easy as they get:

      Name: Support
      Email Address: support@
      Reply-To Address: support@

      Outgoing SMTP Server: mail..com
      Port: 25
      Connection Encryption: None
      Authentication: None

      To: me@
      Subject: Test Email
      Message: Get(CurrentTimeStamp) - calculation used to test emails in timestamp order.

      3. Our email server runs on OS X Server with Squirrel Mail/Postfix. The server is set to allow internal relays of any email using 127.0.0.1/8. I even went so far as to add a special exception for the Windows XP IP address, which of course did not help either.

      Actual result

      The emails all go through and are received just fine from OS X. The emails always encounter error 1506 from Windows.

      Exact text of any error message(s) that appear

      Error 1506 Emails could not be sent.

      Workaround

      There still does not seem to be any work around for the SMTP feature on Windows since it was implemented in FileMaker 10. TSGal, do you have any idea how to get the SMTP feature to work for Windows users?

        • 1. Re: SMTP Error 1506 on Windows XP SP3
          tduell_1

          After several days of research I finally found a solution to this specific problem that I know many people have run accross since FileMaker 10 with the Send Mail function working on their OS X Mail clients, but not their Windows Outlook clients. The problem isn't to do with FileMaker (per say). It has to do with the Windows OS not sending the FQHN (fully qualified host name) in the email header. It so happens that on OS X Server (Snow Leopard 10.6.x) Postfix is fairly well locked down to prevent open relays and spam from propagating. Anything suspect or non-conforming is immediately rejected. Needless to say, since Microsoft is not sending a FQHN with the email it is rejected every time by the Postfix server and returns the dreaded FileMaker 1506 generic error message. To resolve this you have to edit the Postfix config file. Here's the steps:

           

          1. On your OS X Server, open the Terminal application and log in as the root account with the password

          sudo -s

           

          2. Edit the Postfix main.cf file using Pico text editor.

           

          Pico /etc/postfix/main.cf

           

          3. Change the smtpd_helo_restrictions configuration setting (I actually just commented out the original code and added the new line so I can always swtich back if necessary):

           

          smtpd_helo_restrictions = reject_invalid_helo_hostname reject_non_fqdn_helo_hostname

          to

          smtpd_helo_restrictions = permit_sasl_authenticated permit_mynetworks reject_invalid_helo_hostname reject_non_fqdn_helo_hostname

           

          4. Write out the file to save the changes.

           

          5. Finally, relaod the Postfix config file using Terminal.

           

          sudo postfix reload

           

          That did it for me. Once I changed the Postfix settings I was able to use Send Mail from any Windows Outlook client using OS X Server's Postifx mail application. On another note, if you don't want to custom configure your Postifx server you can always use SMTPit from CNS to bypass/correct the headers by going direct to the server. The only thing you'll need to make sure you do is to add the DNS suffix for your domain (i.e. mydomain.com) to the System Properties>Computer Name>Change>DNS suffix. That will force the plugin to send your FQHN in the correct format as username.domain_name (i.e. tduell.mydomain.com).

           

          Hopefully this helps everyone on the OS X/Mail side cope with Windows/Outlook users and the FileMaker Send Mail function.