AnsweredAssumed Answered

Summary field with type Count of does not always work

Question asked by smaros on Jul 13, 2009
Latest reply on Jun 15, 2012 by philmodjunk

Summary

Summary field with type Count of does not always work

Description of the issue

FileMaker Product(s) involved:FileMaker Pro 8, FileMaker Pro 9, FileMaker Pro 10 (The problem does not exist in FileMaker Pro 7) Operating System(s) involved:Mac OS X 10.5 and Windows XP SP3Maybe others too. Detailed description of the issue:The summary field Count of does not correctly count non-empty fields if the field contains specific texts. Example: "zxcvbnm,.asdfghjklqwertyuiop12345678"  Exact steps to reproduce the issue:1. Create a database2. Create a text field3. Create a Summary field, with option Count of text 4. Exit the Manage Database dialog 5. Create a record and enter any text in the text field6. Commit the record and the summary field should show the current count of records with non-empty text fields (1)7. Create a record and enter "0e800" in the text field8. Commit the record and the summary field does not show the correct result. (still 1) Expected Result: In a database with 6 non-empty records, the result shoud be 6. Actual Result:In some cases, the result is less than 6. Exact text of any error message(s) that appeared:N/AAny additional configuration information/troubleshooting that is relevant to the issue:The bug shows only when the text contains these three parts at once.1. The first part must contain the number zero (0) or a decimal separator (. or , depending on the operating system's international settings)2. The second must contain the letter E (upper or lower case)3. The third part must contain numbers that makes an integer >799 Any number of other characters may be used as filling, and the bug still appears. Examples of values of the text field that confirms the bug:0e800Visual Studio .Net Reference, page 10-25 (if you use American decimal point)Orwell, George - 1984 paperback (if you use European decimal comma)   Any workarounds that you have found: None. 

Outcomes