7 Replies Latest reply on Dec 4, 2013 3:15 PM by philmodjunk

    Text attributes seem wrong for normal state

    Fred(CH)

      Summary

      Text attributes seem wrong for normal state

      Product

      FileMaker Pro

      Version

      12.0v4 (Advanced)

      Operating system version

      Mac OS X 10.8.3 and Windows 7

      Description of the issue

      In Layout Mode, the text's display for layout objects can be wrong for normal state. For instance, you defined that, only when pressed, your button must have bold text and red solid colored fill, FileMaker will display a bold text with the original grey gradient fill.

      Steps to reproduce the problem

      STEP 1
      Enter on a layout in layout mode

      STEP 2
      Create a button

      STEP 3
      On it, define a different text appearance for the state "when pressed" with the inspector

      STEP 4
      Click outwards the button or on another layout object WITHOUT DEFINING THE OBJECT'S STATE TO NORMAL on the inspector

      Expected result

      On the inspector, the state activated is automatically "Normal"
      On layout, your object have Normal attributes for fill, line and text formatting.

      Actual result

      On the inspector, the state activated is automatically "Normal"
      On layout, your object have Normal attributes for fill, line BUT text formatting is that for pressed state.

      Exact text of any error message(s) that appear

      None

      Configuration information

      See above

      Workaround

      On the inspector, just after defining the object's special state properties, define the state to Normal, before exit object's focus.