2 Replies Latest reply on Mar 4, 2011 1:53 AM by jvw

    Text Character Clipping Issue

      Summary

      Text Character Clipping Issue

      Product

      FileMaker Pro

      Version

      8.5

      Operating system version

      Mac OSX 10.4

      Description of the issue

      I've got a calculation field using various If statements to increase/decrease displayed text size (using TextSize) depending on number of characters entered. The field also use TextFont to define the font required when viewing/printing.
      My problem is that the £ text character clips at the top. Alignment of the field has to be top aligned (for other fields to align up depending on different text sizing situations). Adding space before doesn't do anything, and the field is not a Merge field (the only mention I could find of a similar problem relating to merge fields).
      Any ideas?

      screen-capture.png

        • 1. Re: Text Character Clipping Issue
          philmodjunk

          Is the currency symbol in a separate field or the same field as the amount? I would guess that it's the same field here.

          On the inspector there are two types of "alignment options". Can you confirm that for this field, you've specified Top alignment in the paragraph section on the Appearance tab of the inspector?

          Can you confirm that it's not styled as "superscript"?

          I hate to suggest this work around, but adding a blank line of text (you can use ¶) above your price, but with a very small font size might be worth an experiment of two...

          • 2. Re: Text Character Clipping Issue

            Many thanks for that. The currency symbol and the amount are in one field. The field is top aligned and when a currency symbol is required its by calculation as superscript placement. I'll try the blank line runaround, I reckon it's just a font issue, but this is the font I have to use.