AnsweredAssumed Answered

The "general" field format feature does not work.

Question asked by dentaldoc on Aug 31, 2011
Latest reply on Aug 31, 2011 by philmodjunk

Summary

The "general" field format feature does not work.

Product

FileMaker Pro

Version

11.0.3

Operating system version

OS X 10.6.8

Description of the issue

In your "FileMaker Pro 11 Help" database (Home > Designing and creating databases > Editing objects on layouts > Formatting text) in the "Notes" section it says,

"In Layout mode, if you specify text formatting with no text or fields selected, you set default text formats for fields and text that you add later. Similarly, if you've just created a field or typed text and it's still selected, and you specify text formatting, you set default text formats. If you change these default text formats later, FileMaker Pro does not retroactively change previously applied formats."

This feature does not work. For example, one of my files somehow acquired the font Erasure, size 36 points, color red, and center justified. Now, no matter what I try to change the default settings, it always defaults to the same 36 pt Erasure settings. For example, if I create a new field, always that same giant red font, no mater what I do prior to creating the field.

I have tried every trick I know. I even tried EXACTLY following the instructions above. NO LUCK! It refuses to change. I can of course change the settings and use them, but when I close the file and reopen it, any new field I might create stubbornly goes back to that giant red Erasure!

I have used FMP a long time. It always worked in previous versions.

Steps to reproduce the problem

I followed exactly the instructions in the Notes section of the FileMaker Pro Help (Home > Designing and creating databases > Editing objects on layouts > Formatting text)

then I close FMP and reopen it. Same wrong default!

Expected result

I expect it to have the attributes of the new settings, for example font Gill Sans, size 12, black

Actual result

Erasure, 36 point, red, center justified;

Exact text of any error message(s) that appear

No error message

Workaround

I have to keep resetting the font, size, color, etc. every time. This is getting tiresome!

Outcomes