AnsweredAssumed Answered

Tibetan Unicode Input Problems

Question asked by cjl108 on Apr 22, 2012
Latest reply on Apr 23, 2012 by TSGal

Summary

Tibetan Unicode Input Problems

Product

FileMaker Pro

Version

12.x

Operating system version

Mac OSX 10.6+

Description of the issue

When typing Tibetan text using Mac's Tibetan-Wylie keyboard, there are a few characters that do not display properly. I have not tried all possibilities, but there are a few key ones I have found not to work. (there were quite a few issues in FM11, quite a bit of improvement in FM12)

Specifically, typing a long"a" (i.e. tA compared with ta) does not produce the proper character

It seems that FM interferes with the tibet keyboard input system. When displaying Tibetan fonts within Filemaker, there are no problems, I can copy and paste Tibetan Unicode text from TextEdit into a field and it displays no problem.

This was tried on OS 6.8 and OS 7.3

Steps to reproduce the problem

with the Tibetan - Wylie keyboard enabled, type the following in a text field in FM12:
ka kA ki kI ga gA gi gI
ta tA ti tI da dA di dI

do not copy and paste this, type it out, and it IS case sensitive.

Expected result

ཀ་ཀཱ་ཀི་ཀཱི་ག་གཱ་གི་གཱི་
ཏ་ཏཱ་ཏི་ཏཱི་ད་དཱ་དི་དཱི་

Actual result

ཀ་ཀ་ཀི་ཀཱི་ག་ག་གི་གཱི་
ཏ་ཏ་ཏི་ཏཱི་ད་ད་དི་དཱི་

Notice the 2nd and 6th character in each row. In FM12, the bottom of the character is missing.

Screen_shot_2012-04-20_at_11.49.38_AM.png

Outcomes