1 2 Previous Next 22 Replies Latest reply on May 24, 2010 2:45 AM by barefootguru

    Turning on Instant Web Publishing (IWP) crashes Filemaker

    jeremyc0

      Summary

      Turning on Instant Web Publishing (IWP) crashes Filemaker

      Description of the issue

      Hi,Details are below. Thanks for your time.-Jeremy  FileMaker Product(s) involved:FileMaker Pro 9.0v3 Operating System(s) involved:Mac 10.4.11 Detailed description of the issue:When I try to turn on IWP,  filemaker closes right after I click "ok." This happens both with the database I created and with a sample database that came with Filemaker.Exact steps to reproduce the issue:1. Open a database2. Go to File > Sharing > IWP3. Click "on" and select a database. The IP address shows up correctly.4. Click "ok" Expected Result: Web publishing should start.Actual Result:Filemaker crashes/exits unexpectedly. Exact text of any error message(s) that appeared:None.Any additional configuration information/troubleshooting that is relevant to the issue:Computer is a G5 with lots of RAM (uncertain of how much, but it's been upgraded). Any workarounds that you have found:None.

        • 1. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
          TSGal

          Jeremy:

           

          Thank you for your post.

           

          I'm curious to know if there is a general problem with the network.  Therefore, go into "File -> Sharing -> FileMaker Network..."  Let's turn this on, select all currently open files, and set these to "All users".  Click "OK" and see if this works.

           

          If this doesn't work, then we have some OS issues.  If this does work, then return to "File -> Sharing -> Instant Web Publishing...", turn it on, select a file and set it to All Users.  Click OK and see if there is still an issue.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
            jeremyc0
              

            Hi there,

             

            Thanks for the quick response; I just tried it out and turning on the Filemaker network worked fine, but unfortunately when I tried turning on IWP the program crashed again. I tried it twice; same outcome both times.

             

             

            Thanks,

            Jeremy

             

            • 3. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
              TSGal

              Jeremy:

               

              Thanks for checking this out.  No problems with the network, which is good.

               

              I still don't have a good idea where the problem lies, but my first inclination is you may have some corrupted preferences.  Go to:

               

              Hard Disk -> Applications -> FileMaker Pro 9 -> Extensions > Web Support

              ....and trash the web.prefs file.

               

              If that doesn't work, then I would also trash the user preference file at:

               

              Home -> Library -> Preferences -> com.filemaker.pro.plist

               

              Finally, I would use uninstall (deactivate) FileMaker Pro, and run "Disk Utility" to repair disk permissions.  If you want, you can make a new Admin user and run it from there.  Disk Utility can be found:

               

              Hard Disk -> Applications -> Utilities -> Disk Utility

               

              I'm hoping one of these things is the culprit.  Please continue to keep me posted.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                jeremyc0
                  

                Hi there,

                 

                I just got around to trying those three things; no dice, although a fair number (I'd guess around 10-20) of permissions were repaired. Any other ideas?

                 

                I also wanted to point out that I'm running a version of Filemaker given to me from an organization that I'm a part of -- they have a license for my group, and I have to run Filemaker with a keyserver. I wonder if this somehow affected something. When I installed, I installed from a .dmg file. Maybe it was incorrectly packaged somehow...?

                 

                 

                Thanks so much for your help.

                -Jeremy

                • 5. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                  TSGal

                  jeremyc0:

                   

                  Thanks for checking everything.

                   

                  Check your FileMaker extensions folder and make sure you have "Web.fmplugin" file, and also in that folder, open the Web Support folder and make sure the application "FM Web Publishing" is present.

                   

                  Is IIS running on the same machine?  Are your files set to use port 80?  Try stopping the "World Wide Publishing" service first, and then enabling Instant Web Publishing?

                   

                  I would also try changing the port to 591, as this port is registered to FileMaker.  That is, pull down the File menu and select "Sharing -> Instant Web Publishing..."  Click on Advanced Options and change the port from 80 to 591.

                   

                  I would then need to try a full install, so you may want to talk to the person who gave you the dmg file.

                   

                  Please continue to keep me posted!

                   

                  TSGal

                  FileMaker, Inc.

                  • 6. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                    jeremyc0
                      

                    Hey there,

                     

                    It looks like all the files are there; unfortunately, I don't know what IIS is, but I think that this computer *is* configured for some sort of remote access (the main user accesses it from home, I believe). I also don't know how to disable the World Wide Publishing service... anyway, might that conflict with anything?

                     

                    An interesting thing happened when I tried changing the port to 591, though -- the program crashed again, right after clicking "ok" to change the port settings (and before turning iwp on). Could this mean some problem with writing the preferences...?

                     

                     

                    I'm sorry that I'm not very familiar with Macs... thanks for your continued support.

                     

                    -Jeremy

                     

                     

                    • 7. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                      TSGal

                      jeremyc0:

                       

                      This information does help.

                       

                      Before clicking OK, let me know all of the settings you have in that dialog box.  That is, under "Status Area Language", I'm assuming you are using English.  What other languages are listed?

                       

                      Under "Advanced Options", what selections are checked?

                       

                      If you click OK after pressing OK to the port, that should not crash either.

                       

                      For the file itself, is it set for All users or Specify users by privilege set?

                       

                      Any additional information would be helpful.

                       

                      My gut feeling is to uninstall FileMaker, remove all traces of FileMaker (not your files) from the hard drive and reinstall again.

                       

                      TSGal

                      FileMaker, Inc. 

                      • 8. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                        jeremyc0
                          

                        Hi there,

                         

                        Thanks again for the help. As a quick aside (I'm just letting you know whatever happens in case it provides more clues), this time when I opened Filemaker, I got an error: "FileMaker cannot share a file because FileMaker  network sharing is turned off." I checked, the Filemaker network sharing was turned off; turning it on got rid of that message. Maybe it got turned off when I deleted some of the preferene files or something.

                         

                        Under "Status Area Language," I believe there has never been a language selected; it looks like no languages are available, too...

                         

                        Under advanced options, the port is defaulted to 80; regardless of whether I change it, the program crashes if I click "ok" here (not if I hit "cancel"). None of the checkboxes ("accessible only from these IP addresses", "script errors", "web publishing errors", and "web activity") are checked, and the default number in "disconnect inactive accounts:" is 0 (which I am forced to change, since it accepts only 1-60). 

                         

                        For access, I've been doing "all users"; just tried "specify users by privilege set," and it crashed when I hit the final "ok" to turn on IWP.

                         

                         

                         

                        It sounds to me like something might be fishy with the .dmg I used to install -- presumably there should be a list of languages available. I'll send an email to the group that manages our license and see what they have to say.

                         

                         

                        Thanks again,

                        Jeremy 

                        • 9. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                          TSGal

                          jeremyc0:

                           

                          Yes, you should definitely have a listing of languages under the "Status Area Language" pop-up.  As I look over past cases, a couple of other people had similar problems with the "Status Area Language" being empty.  Unfortunately, no solution was given on these cases.  The only common thread on those two cases is that they both had a previous version of FileMaker Pro installed on their hard disk.  I have several versions on my hard disk, so that may not be the problem, but thought I should mention it anyway.

                           

                          Do you have access to another machine for testing purposes?  The .dmg file could be fine.  I would try the install there and then see if the language information is displayed.

                           

                          Obviously, I'm fishing because I don't have a clear-cut answer.  Anything you discover would be greatly appreciated.

                           

                          TSGal

                          FileMaker, Inc. 

                          • 10. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                            jeremyc0
                              

                            Hi there,

                             

                            I just wanted to let you know that I'll be talking with the IT group that administers FM, and if he *can* get it to work, I'll post again with a fix... otherwise, I realized that I can actually install it on a PC we have nearby, and that I can probably just host it there.

                             

                            Thanks again for all of your help.

                             

                            -Jeremy

                            • 11. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                              RBD2
                                

                              After reading everything in this post, I am having the exact same problem, and have tried all the same solutions, with no resolution.    I see that the last post was a few months ago without any resolution.  As I said, I have tried all the same fixes, and a couple more.  I still can not enable IWP without an immediate crash.  I also have now Status Area Language selectable.  Has anyone been able to resolve this?

                               

                              Thanks

                               

                              • 12. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                                RBD2
                                  

                                Another piece to the puzzle that might help, is that it does work from root.  But if I create a brand new user account, it is still a crash.  As stated above, all solutions tried.  Including repairing permissions, and verifying the disk.   

                                 

                                Hope this will lead someone to a solution.  It must have somethings to do with the lack of language selection?

                                 

                                 

                                • 13. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                                  jeremyc0
                                    

                                  Hey there,

                                   

                                  I'm still interested in a solution, too.

                                   

                                   

                                  Jeremy

                                  • 14. Re: Turning on Instant Web Publishing (IWP) crashes Filemaker
                                    TSGal

                                    RBD2 and jeremyc0:

                                     

                                    I did manage to get access to a Mac with Tiger (10.4.12) and FileMaker Pro 9.0v3, and I'm still unable to duplicate the problem.  This is what I did:

                                     

                                    1. I created a database "TEST.fp7" with one field.

                                     

                                    2. I turned on Instant Web Publishing.  Prior to turning on Instant Web publishing, the Status Area Language was blank and grayed out.  Once it was turned on, then the Status Area Language (English) appeared, so that is expected.

                                     

                                    3. After turning on Instant Web Publishing, I selected the database and set the access to "All Users".

                                     

                                    4. I went to another machine, launched a browser, and accessed the other database file. 

                                     

                                    Looking over the trouble-shooting steps from this thread, I would also add removing the preferences folder from the home directory.  Then, try again.  Also, make sure you don't have any other applications running concurrently (only for testing purposes - I'm trying to factor out any other variables).

                                     

                                    When you get the crash, is there an error message?  Or, does it freeze?  Quit without an error message?

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 Previous Next