1 2 Previous Next 18 Replies Latest reply on Mar 19, 2012 9:34 PM by Straightline

    Unable to drag fields in Layout

    ChrisCapener

      Summary

      Unable to drag fields in Layout

      Product

      FileMaker Pro

      Version

      11.0v4

      Operating system version

      Mac OS X 10.6.8

      Description of the issue

      In Edit Layout mode, dragging a field with the mouse just drags a gray representation of the field.  The field snaps back to its original location.  The field can be repositioned via the arrow keys.

      Steps to reproduce the problem

      Create a new database.
      Add some fields.
      Press the Edit Layout button.
      Try to reposition a field by dragging with the mouse.

      Expected result

      The field should snap to a new location.

      Actual result

      The field cannot be moved.

      Configuration information

      I installed a fresh copy of FMP 11 from disk.  Updating to v4 made no difference.
      Trashing com.filemaker.client.pro.plist made no difference.

        • 1. Re: Unable to drag fields in Layout
          philmodjunk

          If you create a brand new filemaker database file, do you get the same behavior?

          • 2. Re: Unable to drag fields in Layout
            ChrisCapener

            Yes, creating a new database has the same behavior.  I have also replicated the problem on a second machine.

            • 3. Re: Unable to drag fields in Layout
              ChrisCapener

              Some additional information.  When I click down on a field, the text base line does extend accross the layout.  But the moment I drag the field the line disappears.

              • 4. Re: Unable to drag fields in Layout
                JohnOliver

                Was there ever any resolution to this? I'm having the same problem on osx10.7.2 w/ 11v4

                • 5. Re: Unable to drag fields in Layout
                  ChrisCapener

                  No.  I still have the problem.  No response from Filemaker.

                  • 6. Re: Unable to drag fields in Layout
                    user15307

                    Chris Capener,

                     

                    Thank you for your post.  I apologize for the late reply.

                    I have been unable to replicate this issue on a Mac running OS X 10.6.8, using FileMaker Pro 11.0v4. The machine is a Mac Pro with original Apple Keyboard and a wired Apple mouse.

                    It's helpful that you re-installed and tried a different machine.  I would like to get as much detail about your configurations to understand what is different, and can try to replicate here under like conditions.

                    John Oliver,

                    Thank you for adding your post. I also have tried to replicate this on a Mac with OS X 10.7.2 and cannot. Can you add details about your configuration that may help?

                     

                    TSTuatara

                    FileMaker, Inc.

                    • 7. Re: Unable to drag fields in Layout
                      JohnOliver

                      So, I'm having the problem on a 2009 MacBook Pro (2.53Ghz Intel Core 2 Duo, 8GB DDR3, Intel X25 SSD + 1TB HDD) 

                      I'm running Lion 10.7.2 and Filemaker Pro 11.0v4. 

                      I made a quick screencast (sorry for low resolution) of what happens, check it out here:

                      http://youtu.be/uA2sO69Uj7M

                      Long story short, it does the animation/effect that you get when you try to drag something someplace that it doesn't want to/ can't go. 

                      i.e. The object becomes semi-transparent, dims a bit, then moves... upon mouse release it does the animation of the object returning to the original location like it was attached to a rubber band. 

                      I installed FM11 on my Windows Laptop and it worked fine, I'm going to resort to running it on my Mac in a parallels session if I can't get this to work. 

                      Thanks

                      • 8. Re: Unable to drag fields in Layout
                        user15307

                        John Oliver,

                        Thank you for the additional information.

                        Since I am not able to replicate the behavior on two different Macs, perhaps we can identify if there is anything else in your configuration that may be causing this.

                        1. Have you tried creating an entirely new FileMaker File and yet it still occurs?

                        2. Do you have any plug-ins or other third-party software that could be a factor? 

                        3. Is your user account an Admin?  -- Try creating a new Admin account (will have no login items) and test it in a new database file, if you can.

                        Thank you,

                        TSTuatara

                        FileMaker, Inc.

                        • 9. Re: Unable to drag fields in Layout
                          JohnOliver

                          Hi, to answer your questions:

                          1. The problem occurs regardless of whether the file is new or old. It only happens on my Mac, but not my co-workers. He's running Snow Leopard, not Lion.

                          2. I had the AutoUpdate plug-in and ThemeStudio plug-in, but both are disabled and the problem still persists. 

                          3. I've tried making a new admin account and seeing if that works, but that didn't help either.

                          Thanks,

                          • 10. Re: Unable to drag fields in Layout
                            user15307

                            John Oliver,

                            Thank you.

                            I'll forward this additional information to Development and Testing to see if it can be replicated in-house.

                             

                            TSTuatara

                            FileMaker, Inc.

                            • 11. Re: Unable to drag fields in Layout
                              philmodjunk

                              I thought this issue looked familiar so I did some forum searching. I found one case where a person reported the same problem, but was then able to solve it: Moving fields in form edit mode does not work

                              Not a lot of detail there, but the fact that dragging fields worked on a mac that had no other applications installed suggests a conflict with something else installed on your machine might be causing the issue.

                              • 12. Re: Unable to drag fields in Layout
                                JohnOliver

                                Thanks for the message PhilModJunk, but alas, from that other post I can't figure out what to do/change to get the problem to go away. 

                                I happily concede that others, many many many others do not have this problem and it is something in my Macbook in terms of software or hardware that is causing this problem. My problem is that I have no idea what the cause or fix may be, as I can't just go about deleting my OS to get FM to work.

                                • 13. Re: Unable to drag fields in Layout
                                  JohnOliver

                                  One more piece of information; I just updated to OSx 10.7.3 and it had no effect on the problem. 

                                  • 14. Re: Unable to drag fields in Layout
                                    LuckyChoi

                                    Here’s more data for the Development and Testing Team that could be helpful.

                                    My issue is almost identical. I noticed it soon after I upgraded from Leopard to Snow Leopard although cause and effect is inconclusive.

                                    PROBLEM:

                                    Cannot move or resize objects using mouse or touch pad in Layout Mode.

                                    WHAT HAPPENS:

                                    Am able to click and display the object selection handles, but not reposition or resize objects with mouse or touch pad. Arrow keys work as does the Align and Distribute commands.

                                    DIFFERENCES:

                                    No gray image of the object appears when I try to drag it.

                                    CONFIGURATION:

                                    MacBook Pro 4, 1

                                    2.5 GHz Intel Core 2 Duo

                                    Mac OS 10.6.8

                                    FileMaker Pro 10.0v1

                                    RECENT MODIFICATIONS:

                                    Upgraded from Mac OS 10.5.3. All system updates complete. No further installations.

                                    STEPS TAKEN:

                                    Have followed the recommendations as posted above. Issue persists.

                                    Thank you all for addressing the issue. I hope this helps.

                                    1 2 Previous Next