1 Reply Latest reply on Apr 9, 2009 8:23 AM by TSGal

    Unable to import a time field from a CSV file

    user232

      Summary

      Unable to import a time field from a CSV file

      Description of the issue

      In FMP Advanced 6.0v4 I was able to import a time directly from a CSV file without needing a workaround. In both FMP Advanced 9.0v3 and 10.0v1 I'm unable to import a time from a CSV file. The text stream in a record looks like"$ 0.00",08:36:00,"03/20/07","Fixing PO printing","Billed on IN307" and all of the fields import correctly except the time  (08:36:00)  which imports as a null in the FileMaker record. I've tried enclosing the time field in double quotes but get the same result. As a workaround I can open the CSV file using either version of FMP Advanced, save it as a FileMaker .fp7 file and then import those .fp7 records and all the fields will import correctly. Has anyone else noticed this?

        • 1. Re: Unable to import a time field from a CSV file
          TSGal

          Berrywood:

           

          Thank you for your post.

           

          I copied your example, pasted it into a Text Editor, and saved the file as Test.csv.  I launched FileMaker Pro 10 and created a database file with a Number field, Time field, Date field, and two text fields.  I imported the Test.csv file and all the data came across correctly.  I imported the same file a second time.  I created a Summary field that was a total of the Time field, and the result was 17:12:00.

           

          I don't know why it isn't working for you, and I know that doesn't help you.  Since your CSV file probably doesn't just have one record, I would like to try the import using your CSV file.  I have sent you a private message (top of this screen - right side - X Messages) with instructions where to send the CSV file.

           

          TSGal

          FileMaker, Inc.