8 Replies Latest reply on Jun 10, 2014 2:40 PM by philmodjunk

    Unable to turn off field validation

    mprand

      Summary

      Unable to turn off field validation

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      MacOS 10.7.5

      Description of the issue

      I had a field being validated by calculation and not empty/unique - calc= first 6 digits of the project number must equal the company id.  I first tried to add in the ability to override, but it did not work...still forced to revert. (Override worked in FM11). I also tried removing the calculation so it was just validating on unique and not empty as there are now some situations where the company id and the beginning of the project number may not match. I also changed the custom message.  the behavior was exactly the same as previous, along with the old custom message.  I've now turned off the validation altogether and the behavior continues to be the same as the original set-up.  What am I missing?

      Steps to reproduce the problem

      project set up screen
      1- enter company id - pops in details of that company from the customer table or if new company, enter new custom details
      2- enter project number and other details of the project
      3- commit the record
      4- if first 6 digits of the project number do not match the company id, then a validation error box pops up with a customer message and the user is forced to revert
      (this continues to happen no matter what changes I make to the validation options on the project number field.)

      Expected result

      At step 4, if first 6 digits of the project number do not match the company id, user should be able to override the validation rule

      Actual result

      See step 4 above

      ValOptions_Project_number.png

        • 1. Re: Unable to turn off field validation
          RickWhitelaw

               Your screen shot indicates no validation should be taking place. Perhaps, after quitting then restarting the program, you should perform a recover or at least a consistency check on the file.

          • 2. Re: Unable to turn off field validation
            nilsw

                 Have you cleared the calculation before deactivating it? Although this should not do any difference I would be interested in the result. May be you can also try to specify it as true.

                 Nils

            • 3. Re: Unable to turn off field validation
              philmodjunk

                   And make sure that the field you are dealing with on your layout is exactly the same field in the same data source table where you are using Manage | Database | Fields to modify the validation settings. Changing the field options for Field A while still getting the original behavior in Field B would be consistent with what you describe here.

              • 4. Re: Unable to turn off field validation
                mprand

                     filmakergarage - When just turning off the validation didn't work, I did clear the calc and it still acts as thought it did originally.  I'm not sure how to specify it as true with a calc in there....

                     PhilModJunk - I have triple checked that I am dealing with the same field as on the layout.  This validation, with the override capability was working perfectly in Filemaker 11.  We upgraded to Filemaker 12 just recently.

                     Rick - This database has recently been recovered and converted to Filemaker 12 from v11.  Consistency check shows no issues.

                • 5. Re: Unable to turn off field validation
                  Fred(CH)

                       Hello,

                       Not sure to understand but couldn't resist to give a try too wink:

                       Maybe you have initially tried different techniques to control your field's validation, including an "OnRecordValidate" script trigger, and now, you also must clear the trigger ?

                       Bye, Fred 

                  • 6. Re: Unable to turn off field validation
                    TSGal

                         Michelle Prand:

                         If you changed the custom message and the original message still appears, then there is probably another validation being accessed.  "Fred" is probably on the right track.  Check to see if you have any script triggers enabled; especially "OnRecordValidate".

                         If you have FileMaker Pro Advanced, open the Script Debugger and see if any script is being called when committing the record.

                         Keep us updated with any progress.

                         TSGal
                         FileMaker, Inc.

                    • 7. Re: Unable to turn off field validation
                      mprand

                           OK...There were no script triggers and I verified again that I was dealing with the same field as was on my layout.  I pulled a DDR and started looking for all the fields in that table that had validation and I found a field that had the exact same validation as my project_num field.  It is called test_num and it isn't on any layout.  I turned off the validation on that field and it fixed the problem.  Do anyone know of any way these fields could somehow be linked together?  It doesn't make any sense to me.

                      • 8. Re: Unable to turn off field validation
                        philmodjunk

                             Field validations kick in whether the field is on the current layout or not. It would appear that the validations options specified for that field were resulting in this error message as they would be expected to do.