9 Replies Latest reply on Jul 8, 2016 8:03 AM by TSGal

    Unclickable Area When Scroll Bars Set to Show "When Scrolling"



      Unclickable Area When Scroll Bars Set to Show "When Scrolling"


      FileMaker Pro



      Operating system version

      Mac OS X 10.10.4

      Description of the issue

      When portals are set to allow vertical scrolling and set to show scroll bars only when scrolling, the area where the scroll bar would otherwise be is not clickable. This is an issue when a button is placed on the far right side of the portal row: the button is entirely visible, but not clickable over its entire area.

      Steps to reproduce the problem

      1) Create a portal, enable "Allow Vertical Scrolling", and set to show the scroll bar "When Scrolling".
      2) Place a button at the far right side of the portal row. My sample is a 21 pt x 21 pt button to delete the portal row, inset 2 pt from the right edge of the portal.
      3) Switch to Browse mode and attempt to click the button.

      Expected result

      The button activates and in the case of my example deletes the portal row.

      Actual result

      When clicking roughly the right two-thirds of the button, nothing happens. Clicking the far left third of the button works as expected.

      Exact text of any error message(s) that appear


      Configuration information

      The problem is the area where the hidden scroll bar would otherwise be is not clickable. Switching the setting so scroll bars are always shown reveals the problem. This behavior differs from operating system scroll bars. For example, in a Finder window it is possible to click to the very furthest edge of the content, even though a scroll bar covers that portion of the content when scrolling.

      I initially hid scroll bars in hopes of gaining a little extra horizontal real estate in the portal row. Then I found I could not click the entire button. Hiding the scroll bars while keeping the button fully clickable results in an unusable gap at the right side of the portal. This seems to eliminate the benefit of hiding scroll bars.

      See attached screenshots, which show both scroll bar visibility states in both Browse and Layout modes.


      Current Workarounds:

      1) Unhide the scroll bar.
      2) Hide the scroll bar but leave a wide gap.

      Suggested Fixes:

      1) Make FileMaker behavior consistent with OS behavior.
      2) If that is impossible, at the very least Layout mode should indicate the unclickable area so developers will not place objects in that space.