2 Replies Latest reply on Apr 21, 2011 1:20 PM by IanQuinn

    Using the Templates supplied with FM11.3, I can create a new relationship in the relationship graph...

    IanQuinn

      Summary

      Using the Templates supplied with FM11.3, I can create a new relationship in the relationship graph but it does not show in a portal setup.

      Product

      FileMaker Pro

      Version

      11.3

      Operating system version

      Mac OSX 10.6.7

      Description of the issue

      Using the supplied template 'Invoices.FP7' as a starting point I have set up a new relationship in the relationship graph. 

      When I then try to create a portal on the appropriate layout, the relationship is not showing. 

      The problem is the same if I relate to a table in the Invoices file or relate to a table in another FM file.

      If I create my own Files in an attempt to reproduce the problem, I have no problem in creating a working portal.

      I want to avail of the pre existing design and structures in the templates rather than begin from scratch.

      Steps to reproduce the problem

      Open the Invoices template.   Create a new Table 'People' with two fields:  'Person" (text) and 'Company ID' (number)

      Create a second Table Occurrence 'Customers 2'   Create a relationship to 'People' using Customer ID = Company ID

      Go to Layout 'record Detail-Customers'  Create a portal.  The relationship to People does not show as a related table.  (It shows as unrelated, greyed out.  )

      Expected result

      Help in getting a portal such as this to work. 

      I guess that the template has some setting that is preventing the creation of this portal but I have been unable to find it.

      Workaround

      The only workaround that I have found is to create the files from scratch.

      Screen_shot_2011-04-20_at_15.32.31.png