6 Replies Latest reply on Nov 9, 2012 2:21 PM by philmodjunk

    Value List Not Working When Showing Second Field

    cameraeyes

      Summary

      Value List Not Working When Showing Second Field

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac OSX

      Description of the issue

      There is a bug with FMP12 when using a value list with a field which displaying only values from the second field. 

      When will this bug be fixed?

      Steps to reproduce the problem

      Create a value list which uses the first and second field but only display and sorts based on second field.

      Expected result

      value list

      Actual result

      nothing appears.

      Exact text of any error message(s) that appear

      no error message

      Configuration information

      FMP12

      Workaround

      Currently the only work around is to also show the first field (less than ideal) or by checking "include arrow to show and hide field".

        • 1. Re: Value List Not Working When Showing Second Field

               David Vogel:

               Thank you for the post.

               To attempt to replicate this I created a new database file with 3 fields: Value1, Value2, and ValueField. I related Value1 to Value2 via a "self-join" within the same table. 

               So, the relationship is Value1 = Value2.

               I made ValueField into a drop down field with a value list based on Value1 as the first field and Value2 as the second field, and set the value list to display only the values from the second field, Value2. My drop down correctly displays only the second field's values. 

               Since this can be done in a number of ways, am I possibly missing a step to replicate?

               TSFalcon

               FileMaker, Inc.

          • 2. Re: Value List Not Working When Showing Second Field
            philmodjunk

                 This is a known issue.

                 To replicate, try sorting on the secondary field or hiding the primary field:

                 For More Information see:     VALUE LISTS NOT WORKING - when show values only from second field is selected

                 This is one of many acknowledged bugs that can be found in the Known Bug List thread here in the Report an Issue section of the forum.

                 It can also be downloaded as a database file from:    https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip

            • 3. Re: Value List Not Working When Showing Second Field

                   @All:

                   This issue was addressed in FileMaker Pro 12v2.

                   David Vogel and PhilModJunk are either of you able to replicate this behavior in FileMaker Pro 12v2? If so, can either of you provide me a sample file?

                   TSFalcon
                   FileMaker, Inc.
              • 4. Re: Value List Not Working When Showing Second Field
                philmodjunk

                     I've just been quoting the known bugs list.

                     Good to know that 12v2 addressed this issue. The very large number of new bugs in 12 have made keeping the Known Bugs List up to date a major challenge.

                • 5. Re: Value List Not Working When Showing Second Field
                  cameraeyes

                       I am actually still having the problem even with FileMaker Pro 12v3.  The few things I have discovered are that on entry into the field nothing happens but if you hit the escape key the list comes  up and will continue to come up for the rest of the time you are in the database.  As soon as you close it and open it, it happens again and requires the same approach.  Another thing I discovered is if I add another instance of that field with the same value list lookup, it will work for the new field and now work for the original field.

                       So currently I have work arounds yet haven't been able to get the problem to go away completely.  When creating a new FM12 database I am not able to recreate the problem.  I have done a recovery on my file and there doesn't seem to be any issues with the file.  Hundreds of hours have gone into this solution so I am not about to go and completely rebuild it.

                       Any suggestions or ideas are appreciated.

                  • 6. Re: Value List Not Working When Showing Second Field
                    philmodjunk
                         

                              So currently I have work arounds yet haven't been able to get the problem to go away completely.  When creating a new FM12 database I am not able to recreate the problem.

                         That might indicate that your file is damaged, but in a way that recover is unable to correct. It might be interesting to use FMDiff to do a check up on your file. This 3rd pary app may spot an issue that recover missed.