1 2 Previous Next 22 Replies Latest reply on Jul 10, 2014 4:13 PM by weetbicks

    Webdirect Export Field Contents does not work.

    weetbicks

      Summary

      Webdirect Export Field Contents does not work.

      Product

      FileMaker Server

      Version

      13.0

      Operating system version

      OS X 10.8.5

      Description of the issue

      Running Safari 6.1.1

      Attempting to export a container field contents via webdirect using export field contents step. This is a supported step, however after specifying the file name, I get an error screen appearing.

      Steps to reproduce the problem

      1.  PDF inside a container field
      2 Run a script using export field contents script step
      3. It prompts for the filename which I specify and hit OK
      4. New tab opens with a webdirect error screen (see attached photo).

      Expected result

      If it is a supported step I expect this to open the PDF.

      Actual result

      Error screen.

      Some background:
      Webdirect not allowing printing has meant I have to run a Robot FMP client on the server which is setup to poll for new records in a print table.   The Webdirect client wishes to print something so they activate a process that creates a print record.  Server finds that record and carries out the action of producing the output, which it stores in a PDF on the print record.  Client meanwhile is polling for a finished result.  When it detects server has done the print,  it is attempting to export the container and open it.

      NOTE :  While on the ETS program this worked great.  I believe Get(TemporaryPath) was supported in the ETS version of 13 so I was automatically exporting to the temp location and having the PDF automatically open which was awesome,  now in 13 release all the Get path functions are not compatible with webdirect.

      So my next best was to not attempt to auto-export but just run export field contents and have user click "OK" on the dialog.   The dialog gives no path selection,  just asks what filename they want.  I assume that this action is done by exporting the PDF to some folder within webdirect (as suggested by the odd URL it fails on trying to open).

      If exporting a field is not supported in webdirect then please make this clear otherwise I'm wasting my time.

      Exact text of any error message(s) that appear

      See screenshot

      Workaround

      None

      Screen_Shot_2014-02-07_at_8.57.08_AM.png

        • 1. Re: Webdirect Export Field Contents does not work.
          weetbicks

               Further to this:    My robot on server inserts by using "Insert PDF" which is supported and is not returning error so that's fine.

               If I place the container field on the layout in webdirect -  it works when set to view as an image, but it does NOT work when set to view as interactive content, in this scenario I see the following error (see attachment).

               As a picture,  if I right-click on it and choose to export field contents, I get the exact same error as mentioned in my first post,  a broken URL and an error webpage.  Is export not working at all in webdirect?  if I export records manually this at least saves the exported file to my downloads folder,  but exporting field contents is not working.  

                

               My popups are enabled so I'm not blocking anything there.

          • 2. Re: Webdirect Export Field Contents does not work.
            weetbicks

                 Some more information that has come to hand - on a hunch I tried this on a different 13 deployment and it all works fine (albeit Get(TemporaryPath)).

                 The issue I believe is a deployment related issue with our development server setup for FM 13.  It has been buggy for a while now and has a few other issues so we will do a full reinstall to try and resolve this and other issues.   For now it is working okay on another deployment.

            • 3. Re: Webdirect Export Field Contents does not work.
              TSGal

                   Daniel Wood:

                   Thank you for your post.

                   I am unable to replicate the issue under either Mac OS X 10.8.5 (Safari 6.1.1) nor Mac OS X 10.9.1 (Safari 7.0.1).

                   First, make sure the PDF is embedded in the Container field and not referenced.  Also, make sure Safari preferences do NOT block pop-up windows.

                   Try hosting a new FileMaker Pro file with a single container field (named CONTAINER).  Enter a PDF file into CONTAINER and make sure it is embedded and not referenced.

                   Next, create a script as follows:

                      Set Variable [ $FilePath ; Get ( DesktopPath ) & CONTAINER ]
                      Export Field Contents [ CONTAINER ; $FilePath  ]

                   Run the script to ensure the file is exported to the Desktop.  If this works, then modify the script and uncheck the option for "Specify output file" in the Export Field Contents script step.  This will then allow you to specify a field name.  Run the script.

                   Assuming this all works, then access the file via WebDirect and try again.

                   If you are still having difficulty, try using Chrome, and make sure pop-ups are not blocked.

                   Keep me updated with any progress.

                   TSGal
                   FileMaker, Inc.

              • 4. Re: Webdirect Export Field Contents does not work.
                Guillaume

                     Hi I have the same problem on windows 7 both on Chrome and IE

                     The PDF was imported with the FMPro Client in a embedded container (but with external storage)

                     We have a two server (windows 2008 standard R2) configuration so the pdf is stored on the database server (not the webdirect server)

                     Find a screen shot of the message when I try to export manually form the container on WebDirect (the export works fine on Pro client)

                     Guillaume

                • 5. Re: Webdirect Export Field Contents does not work.
                  TSGal

                       Guillaume Raguet:

                       Thank you for your post.

                       Since the files are external to the database, make sure ports 443 and 80 open.

                       In your Browser preferences, also make sure you don't have pop-ups blocked.  This would stop you from exporting, although no 404 error should appear.

                       Any other information you can provide may be helpful.

                       TSGal
                       FileMaker, Inc.

                  • 6. Re: Webdirect Export Field Contents does not work.
                    Guillaume

                         Yes they are open from the outside pointing to the WebDirect server, (but not the Database Server).

                         From  the inside, they are open on both server,

                         and I have also the bug connecting to webdirect locally

                         Thanks

                          

                         PS : I've checked also the popup blocking

                    • 7. Re: Webdirect Export Field Contents does not work.
                      TSGal

                           Guillaume Raguet:

                           Thanks for the additional information.

                           Run a Port Scan (or Netstat) from the server, and also from the remote client to the server.  Verify the necessary ports are open.

                           Since the files are on the Database server, when the Web Server tries to contact the Database server to access those files, make sure those ports (443 and 80) are also open.

                           If you then get it working locally but not externally, then look into Port Forwarding:

                      http://help.filemaker.com/app/answers/detail/a_id/9770

                           Continue to keep me updated with any progress.

                           TSGal
                           FileMaker, Inc.

                      • 8. Re: Webdirect Export Field Contents does not work.
                        weetbicks

                             I believe this could all be stemming from a server deployment issue with the web component.  I moved the database to another server deployment and it works fine, so the problem was with one of our servers.  Our IT person did a full reinstall of FMS13 on that machine and we are still encountering issues with the web component.  Also other issues on this server include the admin console not working correctly, The following is from our IT person:

                              

                             Server: Mac Mini with OSX 10.9.1, fresh install with apache enabled. Firewall is turned off.
                             Installer: fms_13.0.1.224.dmg
                              
                             After fresh install of FileMaker Server 13 everything works fine, all status lights in admin console are green, and admin console is available from other computers. (Port used is 16001 for some reason).
                              
                             After restart of server, admin console is greyed out for webserver and Filemaker website and admin console not available from external computers. However, everything works fine from the server itself.
                              
                             A redeployment does not change the situation. The depoyment process tests the webserver and comes back fine, then, when processing the deployment the first output is ‘webserver not available’. Everything else is reported with ‘success’.
                              
                             Apache is definitely running and the publishes it’s default website on port 80. However, nothing on https port 443.
                             —
                              
                             So this is where we are at the moment. Everything seems to run, just not the access to FileMaker services via web from external.
                              
                              
                              
                        • 9. Re: Webdirect Export Field Contents does not work.
                          TSGal

                               Daniel Wood:

                               Thank you for the additional information.

                               For others who come across this post, let me make sure they know what ports are needed.  See Knowledge Base Article #12120:

                          http://help.filemaker.com/app/answers/detail/a_id/12120

                               Since nothing is happening  on port 443, is there any virus protection running on the server?  Any security software at all?  If you run a Port Scan on the server, does it show port 443 as open?

                               I'm a little confused when you say "Apache is definitely running and the publishes it's default website on port 80. However, nothing on https port 443",.  FileMaker Server 13 replaces the "default" apache page with its own page.

                               See if you can access WebDirect using secure site:

                               https://<IP Address>/fmi/webd

                               Continue to keep me updated.

                               TSGal
                               FileMaker, Inc.

                          • 10. Re: Webdirect Export Field Contents does not work.
                            weetbicks

                                 Some more from our IT person:

                                  

                            Well, there might be the issue. The default website is not replaced permanently.

                                  
                                 It might be possible that the issue has to do with us not having Mavericks Server installed on this machine, but only Mavericks? However, according to the system requirements Mavericks standard should work fine.
                                  
                                 Testing the server on https://<ip>/fmi/webd fails, BUT http://<ip>/fmi/webd works
                                  
                                 However, http(s)://<ip>:16000/   and http(s)://<ip>:16001/ both fail.
                                  
                                 On the server, http://localhost:16001/ (yes, port is 16001 not 16000) works, however, https://… does not.
                            • 11. Re: Webdirect Export Field Contents does not work.
                              weetbicks

                                   also, no Anti Virus software running on the machine.

                              • 12. Re: Webdirect Export Field Contents does not work.
                                TSGal

                                     Daniel Wood:

                                     Try entering:

                                     https://<IP Address>:16000/admin-console

                                     That is, your previous instructions did not include "admin-console".  For more information, see page 21 of the FileMaker Server 13 Getting Started Guide:

                                https://fmhelp.filemaker.com/docs/13/en/fms13_getting_started.pdf

                                     TSGal
                                     FileMaker, Inc.

                                • 13. Re: Webdirect Export Field Contents does not work.
                                  weetbicks

                                       from IT:

                                        

                                  Hi,

                                        
                                       sorry for not being more specific. Yes, all combinations of http/s and ports 16000/16001 have been tried with admin-console in URL as well. - No connections…
                                        
                                  • 14. Re: Webdirect Export Field Contents does not work.
                                    TSGal

                                         Daniel Wood:

                                         It's hard putting you as the middle person between your IT person and Technical Support.  Have your IT person contact Technical Support directly.  If you are located in North America, have your IT person call toll-free 800-325-2747, as installation calls are no charge.  If you are located outside North America, please contact the FileMaker office nearest you.

                                         TSGal
                                         FileMaker, Inc.

                                    1 2 Previous Next