2 Replies Latest reply on Jun 19, 2015 2:48 PM by willy_peeters

    WebDirect not starting after upgrade to FM14

    willy_peeters

      Summary

      WebDirect not starting after upgrade to FM14

      Product

      FileMaker Server

      Version

      14.0.2.226

      Operating system version

      WindowsServer 2008 R2

      Description of the issue

      After upgrading from FM13 to FM14 everything works fine except it is no more possible to start WebDirect.
      Accessing the Admin Console can be done without problem.

      Actual result

      The WebDirect pages opens but an error message appears. (see screenshot).

      Exact text of any error message(s) that appear

      Communication Problem
      Take note of any unsaved data. Then close the web browser window and contact the FileMaker Server administrator.

      Configuration information

      Tried several browsers and several operating systems : Chrome 43.0.2357.124 and Safari 7.1.6 on OSX, IE10 on Windows. All gave the same error.

      Schermafbeelding_2015-06-18_om_21.26.31.png

        • 1. Re: WebDirect not starting after upgrade to FM14

          Willy Peeters:

           

          Thank you for the post.

           

          While I am not sure why this worked before and now started failing, I would suggest a clean uninstall and reinstall.

           

          Try the following:

           

          1. Uninstall all of the following from Add/Remove:

           

              a. Any antivirus software (Note: do not reinstall until deployment is finished)

              b. FileMaker Server 14

              c. Java (all versions)

              d. Bonjour

              e. IIS URL Rewrite Module

              f. Microsoft Application Request Routing

              g. Microsoft External Cache for IIS

              h.  Microsoft Visual C++ 2012 Redistributable Package (x64) 

              i. Microsoft Web Farm Framework

           

          2. Remove the IIS role from Server Manager

          3. Delete the inetpub folder located on the C:/ drive

          4. Delete or rename the FileMaker Server folder located on the C:/ drive

           

          Afterwards, reinstall FileMaker Server 14.0.2 with the full installer located in the purchase email. 

           

          Please keep me updated with any progress. 

           

          TSFalcon

          FileMaker, Inc.

          • 2. Re: WebDirect not starting after upgrade to FM14
            willy_peeters

            Hello,

            Problem is solved. Cause was probably the fact that there were several Java versions (7 and 8) on the server.

            What I did :

                   
            • Delete all old Java versions
            •      
            • Running through the deploy again
            •      
            • Restart of the server

            After that it worked.

            And to my satisfaction, the response times of WebDirect are tremendously better!

            Regards,

            Willy Peeters