3 Replies Latest reply on Oct 13, 2014 2:23 PM by TSGal

    Webdirect occasionally freezes on a blank page with only the Status bar on initial load

    DanNoble

      Summary

      Webdirect occasionally freezes on a blank page with only the Status bar on initial load

      Product

      FileMaker Server

      Description of the issue

      I am building a solution that includes hiding the Status bar when the initial WebDirect page loads.  When I load the file in WebDirect, it occasionally freezes on a blank page with only the Status bar.  The only way to get the startup script to complete is to click in the browser.  I have tried changing the order of script steps, swapped my database file with a new file with little to nothing in it, same results.  Happens across OS platforms (Mac/Win) and in all browsers (Safari, Chrome, IE, FF).  I would prefer not to post the URL in this forum, please contact me privately for access to the database URL to test for yourself.

      It doesn't happen all the time, most times it flashes the status bar, as discussed here.  This behavior while not optimal, would likely be acceptable to my client.  The entire process freezing randomly is unacceptable and I will be forced to find another platform for this solution which will cost me money and time that I do not have.  WebDirect works great for my use other than this one quirk, please help me find a fix that will allow this project to continue in FileMaker.

      Steps to reproduce the problem

      The link below is with a different host than I had been using with a brand new FM file with nothing but a single form, no records and a startup script with only show/hide Menubar, show/hide Toolbars and go to layout.

      https://n38.fmphost.com/fmi/webd#vzwnew

      Still freezes occasionally when loading the URL.  Can't blame the hosting company (different host) or my file (fresh file).

        • 1. Re: Webdirect occasionally freezes on a blank page with only the Status bar on initial load
          TSGal

          Dan Noble:

          Thank you for your post.

          Since this happens occasionally, please post the script steps being used so I can try to replicate it here.

          What is the predominant browser and version being used that encounters this issue?  I'll try each browser, but if it occurs more often with one, I can repeat the steps multiple times using that browser.

          The link above does display "Hello World". On a separate issue, there is no option to close the file.

          TSGal
          FileMaker, Inc..

          • 2. Re: Webdirect occasionally freezes on a blank page with only the Status bar on initial load
            DanNoble

            The test file (Hello World) posted is there to illustrate that the issue exists with even the simplest of databases, it is not meant to be a functional database.  The file used can be downloaded from here for your own testing.

            I just refreshed the browser (pick one, they all do it) on the test file and it is stuck on a blank form with the status bar displayed.  Clicking anywhere in the browser brings you to the opening layout as defined in the startup script.  It cannot be the desired functionality to have the file hang randomly.

            This is a huge issue for my client, and I am at a full stop with this project.  Deadline looming nearer, need a resolution or will have to abandon FileMaker for this (and future projects).  Shame of it is, WebDirect works great for the kinds of projects I typically have minus this quirk.

            • 3. Re: Webdirect occasionally freezes on a blank page with only the Status bar on initial load
              TSGal

              Dan Noble:

              I downloaded the file and have it hosted on a Windows Server 2008 R2 and Mac OS X 10.9.5, both running FileMaker Server 13.0v4.  I am still unable to replicate the issue with Chrome (Windows) and Safari (Mac).

              What is the operating system of the n38.fmphost.com server?

              Looking at your script, could it be a refresh issue?  Try clearing the cache, or add a "Refresh Window" script step to the end.  Does this help?

              TSGal
              FileMaker, Inc.