AnsweredAssumed Answered

Will Not Embed Files in Container, fp7 to fmp12, "Insert" Open Storage used.

Question asked by rouelf_1 on Apr 23, 2013
Latest reply on Apr 23, 2013 by rouelf_1

Summary

Will Not Embed Files in Container, fp7 to fmp12, "Insert" Open Storage used.

Product

FileMaker Pro

Version

FMP 12 Adv

Operating system version

OSX and Windows XP

Description of the issue

Converted an fp7 solution to fmp12. Converted containers to external, open storage. Inserted files using Insert File script step, set-up containers (22 per record, many TO) with the "Insert" option (no Reference). Though the save copy as Self-Contained (Single Copy) performs the save, the containers are not deactivated from external storage, and therefore files are not transferred to embed in containers.

Steps to reproduce the problem

Did: 1) Save compacted, 2) Ran recover, no problems found. 3) Saved clone. 4) Re-populated all fields, and containers with "Insert" storage option. 5) Still saves using the Self-Contained (single-Copy), but files are still not embeded in the containers. External Storage will not disengage. Boldly I say, all is not quite right with conversion of complex fp7 solutions.

Expected result

Embed files in containers for transferring to iOS, of course a runtime should also be able to use Save A Copy As ... Self-Contained (Single Copy).

Actual result

No embedding of files in containers. Tried on latest OSX an Windows XP.

Exact text of any error message(s) that appear

No Error Messages.

Workaround

1) Work around is to manually dissengage every container field, not good for disseminating and clients to transfer a runtime to iOS devices.

2) Not use External Storage, and use scripts to change from Reference to files, to Actual embed, files ala FMP11 Adv capability.

Outcomes