AnsweredAssumed Answered

wrong date format on a swissgerman system

Question asked by PatrickR on Jan 6, 2011
Latest reply on Feb 18, 2011 by TSGal

Summary

wrong date format on a swissgerman system

Product

FileMaker Pro

Version

7, 8, 9, 10, 11

Operating system version

Mac OS X any

Description of the issue

Dates are formatted in dd/mm/yyyy in FileMaker by default.
Dates can only be properly formatted with the "Format date" option, which will break the international use of the database, since dates are formatted differently in other countries.

FileMaker does not obey the system settings of the swiss german settings, which are normally dd.mm.yyyy.

Steps to reproduce the problem

1. Create a new file on a Mac OS X system with the swiss german country setting in effect.
2. Create a new date field in the FM file.
3. Enter some date with a script command or the insert date command.

Expected result

The date should be formatted dd.mm.yyyy like it says in the system format.

Actual result

The date is formatted dd/mm/yyyy.

Exact text of any error message(s) that appear

This is a very annoying bug since FM 7. Because every scripted date insert must be customized with things like Day($date) & "."& Month($date) &"." & year($date), but only if the file is openend on a swiss german Mac OS system.

Outcomes