2 Replies Latest reply on Dec 21, 2011 12:33 PM by isisdesign

    XML import field mapping setting no longer ignored in FMP 11

    isisdesign

      Summary

      XML import field mapping setting no longer ignored in FMP 11

      Product

      FileMaker Pro

      Version

      11.0v3

      Operating system version

      Mac OS X 10.6.8

      Description of the issue

      For an in depth description please read  http://forums.filemaker.com/posts/8504da1792. Didn't see the tab for "Report an issue..."

      Summary:

      So to sum up, FMP 9/10 appears to have ignored the "Arrange by:" setting in "Specify import order" settings when importing XML and using XSLT. Now FMPro 11 is not ignoring the "Arrange by:" setting.  If in an import script step of an xml file using xslt you set "Arrange by:" settings to use "matching names" the xml data winds up in the correct fields; if you specify the "Arrange by:" settings to some random order that is not the order as specified in the xslt file, then FMPro puts the data into the wrong fields.

      Steps to reproduce the problem

      1. Specify an import file script step to use XML file with XLST.
      2. Specify the "Arrange by:" settings to use some random specified order that is different than the order of the elements as defined in the XSLT file.
      3. Run the script and the data will be put into the fields as specified by the order in the "Arrange by:" settings, not by element to field name matching as FMPro 9/10 did.

      Expected result

      In FMPro 9/10, the "Arrange by:" setting was ignored and the implied matching of XML/XSLT element names to table field names worked. I expected it to be the same in FMPro 11. Or there should be documentation in the Import script step or the XML import online help to clarify how one should set the "Arrange by:" setting when using XML; there is none.

      Actual result

      In FMPro 11, the "Arrange by:" setting is not ignored and the implied matching of XML/XSLT element names to table field names is ignored and FMPro 11 puts data into the fields as specified in the "Arrange by:" setting.

      Exact text of any error message(s) that appear

      No error message.

      Configuration information

      none.

      Workaround

      Specify "Matching names" in the "Arrange by:" setting. Or is this the way it is supposed to be and FMPro 9/10 had a bug in ignoring the "Arrange by:" setting? Dear Filemaker, please let us know.

        • 1. Re: XML import field mapping setting no longer ignored in FMP 11
          TSGal

          Daniel Melnechuk:

          Thank you for your post, and I apologize for the late reply.

          This is the way it should work.  Other users had reported that the import mapping was ignored in previous versions, and it was fixed in FileMaker Pro 11.

          TSGal
          FileMaker, Inc.

          • 2. Re: XML import field mapping setting no longer ignored in FMP 11
            isisdesign

            Hi TSGal,

            Thanks for getting to this and confirming that this was a decsiion at Filemaker to change the behavior. I would like to point out that this change in behavior was not specified anywhere that i could find online at Filemaker or the net. Please, please, please get back to development that when you change something like this, weather considered a bug fix or an enhancement, you really have to document it in the changes. Instead of spending lots of time tracking this down would not have been lost if i had seen in the change report in FM 11 that there was a change in how this was handled in XML/XLST import.

            On another front, it seems odd that when using XML with or without XLST that you would want to override the fieldname matching of FM fields to XML tagged element data. But then again, i haven't tried to come up with a reason to not. It would be nice to know if the others who reported that it was ignored where complaining because they wanted the capability to not match XML tagged element data to FM fieldnames or just noting it?

            In any case, have a happy Solstice today!

            Peace,
            Dan